[PVE-User] VNC strange behaviour with special characters and AltGr keys

Michael Rasmussen mir at miras.org
Sat May 18 00:35:24 CEST 2013


On Sat, 18 May 2013 00:13:31 +0200
Florent THOMAS <mailinglist at tdeo.fr> wrote:

> Hy Michael,
> 
> I read your postcarefully.
> I changed the modifiers in the appropriate file and reboot the VM and the VNC console, unfortunately the result is the same.
> 
Yes, I have just confirmed that this was a pve-2.2 bug only. Works here
without this change.

I have come to the conclusion that your keyboard layout in the VM
(CentOS 6) might be like this:
Default: us
Your user: nl

The default keyboard is configured here: /etc/sysconfig/keyboard
Try this:
KEYBOARDTYPE="pc"
KEYTABLE="nl"

After this change the VM must be rebooted.

-- 
Hilsen/Regards
Michael Rasmussen

Get my public GnuPG keys:
michael <at> rasmussen <dot> cc
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xD3C9A00E
mir <at> datanom <dot> net
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE501F51C
mir <at> miras <dot> org
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE3E80917
--------------------------------------------------------------
Worlds are conquered, galaxies destroyed -- but a woman is always a
woman. -- Kirk, "The Conscience of the King", stardate 2818.9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20130518/73447cd3/attachment-0013.sig>


More information about the pve-user mailing list