[PVE-User] VNC strange behaviour with special characters and AltGr keys

Florent THOMAS mailinglist at tdeo.fr
Fri May 17 23:53:35 CEST 2013


Hey folks,

Obviously, asking question mostly helps to find new ways of thinking.
Thanks to this ressource : 
http://www.linuxquestions.org/questions/linux-newbie-8/wrong-keyboard-layout-at-boot-659701/ 
two solutions are available for my problem.

Apparently, either I change BIOS options or Grub options.

So where is the BIOS conf in pve and what is the correct option that set 
the keyboard layout.

Thanks for all,


On 17/05/2013 23:40, Florent THOMAS wrote:
> Hy folks,
>
> I'm running the above pve version and I'm having strange issue with 
> VNC console for all kinds of Vm's.
>
> For example, I installed a centos6 as a KVM and as OpenVZ container 
> and the behavior is the same.
> I explain, I have some special characters in my password such as \,^ 
> and stuff like that. The backslash needs to press AltGr key and when I 
> do this it doesn't works. I tried to move with arrows and it doesn't 
> works better.
>
> You would says check your Datacenter keyboard default layout and all 
> the stuff... I made everything of that.
> What is AMAZING, is when I change the pass to a more simple one 
> without special characters. Of course it works but THEN, all the 
> special characters could be written.
>
> SO in the end, the keyboard layout is not recognize by the VNC console 
> BEFORE connexion but is recognized after that.
>
> Does anybody already struggle with something like this?
>
> Regards
>
>
> /pveversion --verbose//
> //pve-manager: 2.3-13 (pve-manager/2.3/7946f1f1)//
> //running kernel: 2.6.32-19-pve//
> //proxmox-ve-2.6.32: 2.3-96//
> //pve-kernel-2.6.32-11-pve: 2.6.32-66//
> //pve-kernel-2.6.32-16-pve: 2.6.32-82//
> //pve-kernel-2.6.32-19-pve: 2.6.32-96//
> //pve-kernel-2.6.32-14-pve: 2.6.32-74//
> //lvm2: 2.02.95-1pve2//
> //clvm: 2.02.95-1pve2//
> //corosync-pve: 1.4.4-4//
> //openais-pve: 1.1.4-2//
> //libqb: 0.10.1-2//
> //redhat-cluster-pve: 3.1.93-2//
> //resource-agents-pve: 3.9.2-3//
> //fence-agents-pve: 3.1.9-1//
> //pve-cluster: 1.0-36//
> //qemu-server: 2.3-20//
> //pve-firmware: 1.0-21//
> //libpve-common-perl: 1.0-49//
> //libpve-access-control: 1.0-26//
> //libpve-storage-perl: 2.3-7//
> //vncterm: 1.0-4//
> //vzctl: 4.0-1pve2//
> //vzprocps: 2.0.11-2 //
> //vzquota: 3.1-1 //
> //pve-qemu-kvm: 1.4-10 //
> //ksm-control-daemon: 1.1-1 /
>
>
>
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20130517/582d1f0b/attachment-0015.html>


More information about the pve-user mailing list