[PVE-User] Question about Proxmox HA

Gilberto Nunes gilberto.nunes32 at gmail.com
Fri Dec 6 21:23:37 CET 2013


I meant: I get it!!!

That's work pretty awsome!!!


2013/11/10 Gilberto Nunes <gilberto.nunes32 at gmail.com>

> That's cool ahmad...
>
> I will try it as soon as I can...
>
> Thanks
>
>
> 2013/11/10 ahmad imanudin <ahmadiman1126 at gmail.com>
>
>>
>>> ----------------------------------------------------------------------
>>>
>>> Message: 1
>>> Date: Fri, 8 Nov 2013 11:40:58 -0200
>>> From: Gilberto Nunes <gilberto.nunes32 at gmail.com>
>>> To: pve-user at pve.proxmox.com
>>> Subject: [PVE-User] Question about Proxmox HA
>>> Message-ID:
>>>         <
>>> CAOKSTBt9Qr05nRKnYpEX2ksQjLL0D_JabRoDYy4N3NUEgs3i6Q at mail.gmail.com>
>>> Content-Type: text/plain; charset=ISO-8859-1
>>>
>>>
>>> Hello
>>>
>>> We have here a cluster created with 3 nodes and a simple storage...
>>> It's just to test porposes...
>>> There is no fence devices, for now.
>>> After setting up all Proxmox Hosts and VM's, when I turn off a VM on
>>> node1, for example, the VM is started on node2.
>>> But when I plugged off the network cable, the some doesn't happen!
>>>
>>> Why? Because the cluster is without fence device??
>>>
>>> Thanks...
>>>
>>
>> Hi Gilberto,
>>
>> I Have been testing Proxmox HA without fencing device and works. I test
>> with 2 nodes Proxmox but have not tried with 3 nodes. I also posting in my
>> blog about howto :
>> http://ahmad.imanudin.com/2013/08/18/tips-proxmox-configure-proxmox-high-availability-without-fencing-device/ with
>> indonesian language :D
>>
>> This is my Cluster configuration
>> *************************************
>> cp /etc/pve/cluster.conf /etc/pve/cluster.conf.new
>> nano /etc/pve/cluster.conf.new
>>
>> *<?xml version="1.0"?>*
>> *<cluster config_version="5" name="excellent">*
>> *<cman expected_votes="1" keyfile="/var/lib/pve-cluster/corosync.authkey"
>> two_node="1"/>*
>> *<fencedevices>*
>> *<fencedevice agent="fence_manual" name="human"/>*
>> *</fencedevices>*
>> *<clusternodes>*
>> *<clusternode name="pve1" nodeid="1" votes="1">*
>> *<fence>*
>> *<method name="single">*
>> *<device name="human" nodename="pve1"/>*
>> *</method>*
>> *</fence>*
>> *</clusternode>*
>> *<clusternode name="pve2" nodeid="2" votes="1">*
>> *<fence>*
>> *<method name="single">*
>> *<device name="human" nodename="pve2"/>*
>> *</method>*
>> *</fence>*
>> *</clusternode>*
>> *</clusternodes>*
>> *</cluster>*
>>
>> Note :
>> excellent = My Cluster name
>> pve1 = Hostname for Proxmox 1 (node 1)
>> pve2 = Hostname for Proxmox 2 (node 2)
>>
>> Importan : You must edit config_version every change cluster
>> configuration.
>>
>> Next you can configure VM with clue from here :
>> http://pve.proxmox.com/wiki/High_Availability_Cluster and try to power
>> off host Proxmox.
>> Example :
>>
>> I have VM running on Proxmox 1 (node1) and have been configured HA.
>> Forced off node 1 and run this command from node 2 to take over VM
>>
>> fence_ack_manual pve1 (pve1 is hostname node 1)
>>
>> after that, you must confirm with answer *absolutely*
>>
>> Thanks
>>
>> --
>>
>>
>> **
>> Best Regards,
>>
>>
>> Ahmad Imanudin -  Sharing is Beautiful !
>> Web : http://ahmad.imanudin.com, YM : ahmad_imanudin
>> FB : http://facebook.com/imanudin11 Twitter : @ahmad_9111
>>
>> _______________________________________________
>> pve-user mailing list
>> pve-user at pve.proxmox.com
>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>
>>
>
>
> --
> Gilberto Ferreira
>



-- 
Gilberto Ferreira
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20131206/3df25fe4/attachment-0015.html>


More information about the pve-user mailing list