[PVE-User] SpiceProxy Bug?

Dietmar Maurer dietmar at proxmox.com
Mon Aug 26 14:01:08 CEST 2013


I guess you need to debug the server side to see what is wrong.


From: Ирек Фасихов [mailto:malmyzh at gmail.com]
Sent: Montag, 26. August 2013 13:53
To: Dietmar Maurer
Cc: pve-user at pve.proxmox.com
Subject: Re: [PVE-User] SpiceProxy Bug?

between downloading and running no more than 10 seconds ...

2013/8/26 Dietmar Maurer <dietmar at proxmox.com<mailto:dietmar at proxmox.com>>
> HTTP proxy connection failed: 401 invalid ticket

I guess the ticket is expired - AFAIK the lifetime is just 30 seconds.


From: pve-user-bounces at pve.proxmox.com<mailto:pve-user-bounces at pve.proxmox.com> [mailto:pve-user-bounces at pve.proxmox.com<mailto:pve-user-bounces at pve.proxmox.com>] On Behalf Of ???? ???????
Sent: Montag, 26. August 2013 13:00
To: pve-user at pve.proxmox.com<mailto:pve-user at pve.proxmox.com>
Subject: [PVE-User] SpiceProxy Bug?

kataklysm at linux-41gj:~/Downloads> cat spiceproxy
[virt-viewer]
ca=-----BEGIN CERTIFICATE-----\nXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX\n-----END CERTIFICATE-----\n
delete-this-file=1
host-subject=C=RU,ST=RU,L=Kirov,O=XXXXXXXXXXXXX,OU=IT,CN=proxmoxnode2.XXXXXXX,emailAddress=admin at XXXXXXXXXXXXXXXXXXXXXXX
host=pvespiceproxy:521b1fba:114:proxmoxNode2::520a3f5a24374c7fe75f784bfd0574e7cce2c85a
password=a0d741eb8aabd7cc869f4525bd4228cf19c3504e
type=spice
title=VM 114
proxy=http://proxmoxnode2.XXXXXXXX:3128<http://proxmoxnode2.xxxxxxxx:3128/>
tls-port=61002


kataklysm at linux-41gj:~/Downloads> telnet proxmoxnode2 3128
Trying 10.43.255.210...
Connected to proxmoxnode2.
Escape character is '^]'.


kataklysm at linux-41gj:~/Downloads> remote-viewer spiceproxy --debug
(remote-viewer:22206): remote-viewer-DEBUG: Insert window 0 0xa25800
(remote-viewer:22206): remote-viewer-DEBUG: fullscreen display 0: 0
(remote-viewer:22206): remote-viewer-DEBUG: Opening display to spiceproxy
(remote-viewer:22206): remote-viewer-DEBUG: Guest spiceproxy has a spice display
(remote-viewer:22206): remote-viewer-DEBUG: After open connection callback fd=-1
(remote-viewer:22206): remote-viewer-DEBUG: Opening connection to display at spiceproxy
(remote-viewer:22206): remote-viewer-DEBUG: New spice channel 0xaa3460 SpiceMainChannel 0
(remote-viewer:22206): remote-viewer-DEBUG: Checking full screen auto-conf
(remote-viewer:22206): remote-viewer-DEBUG: auto-conf disabled
(remote-viewer:22206): remote-viewer-DEBUG: notebook show status 0xa23150

(remote-viewer:22206): GSpice-WARNING **: HTTP proxy connection failed: 401 invalid ticket
(remote-viewer:22206): remote-viewer-DEBUG: main channel: failed to connect
(remote-viewer:22206): remote-viewer-DEBUG: Disposing window 0xa25800

(remote-viewer:22206): remote-viewer-DEBUG: Set connect info: (null),(null),(null),-1,(null),(null),(null),0

In what could be the problem?  The firewall is disabled!  Thank you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20130826/99c0c582/attachment-0015.html>


More information about the pve-user mailing list