[PVE-User] sheepdog tests: cannot remove vm

Fábio Rabelo fabio at fabiorabelo.wiki.br
Thu Oct 25 18:02:16 CEST 2012


After restarting everything the error msg changed to :

TASK ERROR: sheepdog delete vm-1002-disk-1' error: Failed to delete
vm-1002-disk-1: No VDI found

How can I remove this VM ?

Or I will have to begin again from zero again ?!?


Fábio Rabelo



2012/10/25 Fábio Rabelo <fabio at fabiorabelo.wiki.br>

> Thank you , but it do not work .
>
> After restarting sheepdog daemon, the error msg changes to :
>
> TASK ERROR: sheepdog delete vm-1001-disk-1' error: [main] connect_to(243)
> failed to connect to 127.0.0.1:7000: Connection refused
>
> still cannot remove vm ...
>
>
> Fábio Rabelo
>
>
>
> 2012/10/25 Alexandre DERUMIER <aderumier at odiso.com>
>
>> I think that your sheepdog cluster is halted, because you have some nodes
>> down. (you need to have X nodes online, where X is --copies=X).
>>
>> so restart your down sheepdog node, then can remove your disk
>>
>>
>> ----- Mail original -----
>>
>> De: "Fábio Rabelo" <fabio at fabiorabelo.wiki.br>
>> À: pve-user at pve.proxmox.com
>> Envoyé: Jeudi 25 Octobre 2012 14:24:47
>> Objet: [PVE-User] sheepdog tests: cannot remove vm
>>
>> Hi to all
>>
>> During my sheepdog testes, once again images in sheepdog disappeared, but
>> this time I am having troubles removing the vm !
>>
>> The msg are :
>>
>> TASK ERROR: sheepdog delete vm-1001-disk-1' error: Failed to delete
>> vm-1001-disk-1: IO has halted as there are too few living nodes
>>
>> How can I remove this vm to restart sheepdog cluster ?
>>
>> thanks in advance ...
>>
>>
>> Fábio Rabelo
>>
>> _______________________________________________
>> pve-user mailing list
>> pve-user at pve.proxmox.com
>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20121025/c455de01/attachment-0014.html>


More information about the pve-user mailing list