[PVE-User] New KVM 1.2, snapshots, vzctl and other packages on pvetest (on the road to V2.2)

Dietmar Maurer dietmar at proxmox.com
Sun Oct 7 09:14:47 CEST 2012


I already reported that migration bug:

http://bugzilla.openvz.org/show_bug.cgi?id=2242

Maybe you can add a comment (to tell openvz people that bug is still there).


From: pve-user-bounces at pve.proxmox.com [mailto:pve-user-bounces at pve.proxmox.com] On Behalf Of David Black
Sent: Samstag, 06. Oktober 2012 13:48
To: Martin Maurer
Cc: proxmoxve (pve-user at pve.proxmox.com)
Subject: Re: [PVE-User] New KVM 1.2, snapshots, vzctl and other packages on pvetest (on the road to V2.2)

Here's an update: A Fedora 17 CT booted normally.   On the outside chance there was a problem with the host I did the first v2.2 CT tests on, I started a CentOS 6 CT on another host, and it behaved the same way (hung on an init step).

I didn't expect CT live migration (on NFS storage) to necessarily work, but tried anyway.  It worked once, then failed the second time with similar behavior as before.   Seems like it considers the .nfs* lock files disappearing on their own a failure - perhaps they should just be excluded/ignored.   FWIW here's the migration log:

Oct 05 21:39:19 starting migration of CT 114 to node 'ollie' (10.7.65.112)
Oct 05 21:39:19 container is running - using online migration
Oct 05 21:39:19 container data is on shared storage 'tex-pve'
Oct 05 21:39:19 start live migration - suspending container
Oct 05 21:39:19 dump container state
Oct 05 21:39:20 dump 2nd level quota
Oct 05 21:39:21 initialize container on remote node 'ollie'
Oct 05 21:39:21 initializing remote quota
Oct 05 21:39:41 turn on remote quota
Oct 05 21:39:41 load 2nd level quota
Oct 05 21:39:41 starting container on remote node 'ollie'
Oct 05 21:39:41 restore container state
Oct 05 21:39:42 # /usr/bin/ssh -c blowfish -o 'BatchMode=yes' root at 10.7.65.112<mailto:root at 10.7.65.112> vzctl restore 114 --undump --dumpfile /mnt/pve/tex-pve/dump/dump.114 --skip_arpdetect
Oct 05 21:39:41 Restoring container ...
Oct 05 21:39:41 Starting container ...
Oct 05 21:39:41 Container is mounted
Oct 05 21:39:41 undump...
Oct 05 21:39:42 Setting CPU units: 1000
Oct 05 21:39:42 Setting CPUs: 1
Oct 05 21:39:42 Configure veth devices: veth114.0
Oct 05 21:39:42 Adding interface veth114.0 to bridge vmbr1 on CT0 for CT114
Oct 05 21:39:42 vzquota : (warning) Quota is running for id 114 already
Oct 05 21:39:42 Error: undump failed: No such file or directory
Oct 05 21:39:42 Restoring failed:
Oct 05 21:39:42 Error: rst_open_file: failed to lookup path '/tmp/.nfs000000000000c42800000009': -2
Oct 05 21:39:42 Error: can't open file /tmp/.nfs000000000000c42800000009
Oct 05 21:39:42 Error: rst_file: -2 414312
Oct 05 21:39:42 Error: rst_files: -2
Oct 05 21:39:42 Error: make_baby: -2
Oct 05 21:39:42 Error: rst_clone_children
Oct 05 21:39:42 Container is unmounted
Oct 05 21:39:42 ERROR: online migrate failure - Failed to restore container: Container start failed
Oct 05 21:39:42 start final cleanup
Oct 05 21:39:42 ERROR: migration finished with problems (duration 00:00:23)
TASK ERROR: migration problems

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20121007/aa59363a/attachment-0014.html>


More information about the pve-user mailing list