[PVE-User] HA behavior with VMs (PVE 2.2 pre-release)

David Black proxmox at 1000.relay.net
Thu Oct 11 01:58:03 CEST 2012


I think this behavior also existed in PVE 2.1, but only have a pre-2.2 system running right now. 
My configuration is three nodes, with HA enabled. 


A few questions/odd things I'm seeing: 


1. There is an HA-protected VM running on host 1, with the autostart HA attribute set to 0. The VM's "start at boot" option is also 0, but I don't think that matters here. When I shut down RGmanager on host 1 to simulate it going down, HA shuts down the VM on host 1, migrates it (offline) and starts it back up on host 2. Under this circumstance it would be able to live migrate the VM, so why doesn't it do that? That's what I'd like it to do. 


2. What's the difference between an HA migrate and VM migrate? When manually live migrating, I see PVE logging both even for an HA-enabled VM. 


3. Same scenario as #1. I manually shut down the VM on host 1 and a few seconds later it starts up by itself with a "VM start" event. I think it also did this in PVE 2.1. The event log says " task started by HA resource agent" 


4. Same scenario as #1, except I power off host 1 and let it get fenced. Just as in #1, the VM is moved to host 2 and starts up, even though autostart is still zero. If autostart is zero, the VM shouldn't start, right? 


Because of #3, it seems I can't have a powered-off VM sitting there, that will be moved to another host in the event whichever host it's on goes down. Seems like a bug to me. Maybe the behavior of #3 and 4 are related. I want to make all my VMs "protected" by HA whether they're running or not, so they always remain accessible regardless of their powered off/on status. Also, why can't I have an HA-protected VM stay powered off? :-) 


Thoughts? 


Dave 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20121010/4319ee29/attachment-0013.html>


More information about the pve-user mailing list