[PVE-User] Failed to migrate VM from host3 to host1

Maykel Franco Hernández maykel at maykel.sytes.net
Tue May 8 10:51:14 CEST 2012


 

El 2012-05-08 10:35, Holger Ernst escribió: 

> The error 255 comes
from the ssh command itself. 
> 
> Can you use ssh from one host to the
other? Try the exact command with (for example) 'qm list'. Will it work?

> 
> Regards Holger 
> 
> VON: pve-user-bounces at pve.proxmox.com
[mailto:pve-user-bounces at pve.proxmox.com] IM AUFTRAG VON Maykel Franco
Hernández
> GESENDET: Dienstag, 8. Mai 2012 10:18
> AN: proxmox lista
>
BETREFF: Re: [PVE-User] Failed to migrate VM from host3 to host1 
> 
>
El 2012-05-07 17:08, Maykel Franco Hernández escribió: 
> 
>> Hi, I
received this error when I migrate a VM: 
>> 
>> May 07 17:06:01
starting migration of VM 112 to node 'virtual1' (10.100.106.1)
>> May 07
17:06:01 copying disk images
>> May 07 17:06:01 starting VM 112 on
remote node 'virtual1'
>> May 07 17:06:02 ERROR: online migrate failure
- command '/usr/bin/ssh -c blowfish -o 'BatchMode=yes' root at 10.100.106.1
[1] qm start 112 --stateuri tcp --skiplock' failed: exit code 255
>> May
07 17:06:03 ERROR: migration finished with problems (duration
00:00:02)
>> TASK ERROR: migration problems 
>> 
>> Can I help me
please?? 
>> 
>> Thanks in advanced.
> 
> Can I help me please??? I want
migrate the VM between hosts in the cluster....

Thanks for your
replys!! 

Yes, for example: 

root at virtual2:/etc/pve/qemu-server#
/usr/bin/ssh -c blowfish -o 'BatchMode=yes' root at 10.100.106.1 qm list

VMID NAME STATUS MEM(MB) BOOTDISK(GB) PID 
 100 pfsense1 running 1024
25.00 1008916 
 104 pfsense2 running 1024 20.00 2270 
 105 smoothwall3
running 1024 20.00 182870 
root at virtual2:/etc/pve/qemu-server#
/usr/bin/ssh -c blowfish -o 'BatchMode=yes' root at 10.100.106.3 qm list

VMID NAME STATUS MEM(MB) BOOTDISK(GB) PID 
 111 asterisk-reduce stopped
1024 40.00 0 
 112 asterisk-reducido stopped 1024 15.00 0

root at virtual2:/etc/pve/qemu-server# 

The commands exec successfully
from shell, the problem is with rsync, The file qemu configuration is
migrate OK and I see the VM in the other host in the cluster via web
interface proxmox. 

The problem is that the image folder is not passed
correctly to the other node, only migrates the configuration file qemu.
If I manually migrated VM with rsync,the virtual machine boots OK on
another host in the cluster.

 

Links:
------
[1]
mailto:root at 10.100.106.1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20120508/766bdcf8/attachment-0014.html>


More information about the pve-user mailing list