[PVE-User] About backup vm Problem

Dietmar Maurer dietmar at proxmox.com
Tue Mar 6 09:47:40 CET 2012


Are you able to manually remove the snapshot?
# lvremove /dev/dr0vg/vzsnap-R510-0
And please can you also post to the mailing list?
From: lyt_yudi [mailto:lyt_yudi at 126.com]
Sent: Dienstag, 06. März 2012 09:22
To: Dietmar Maurer
Subject: Re: RE: [PVE-User] About backup vm Problem

yes
# uname -a
Linux R510 2.6.32-7-pve #1 SMP Thu Feb 16 09:00:32 CET 2012 x86_64 GNU/Linux

# pveversion -v
pve-manager: 2.0-38 (pve-manager/2.0/af81df02)
running kernel: 2.6.32-7-pve
proxmox-ve-2.6.32: 2.0-60
pve-kernel-2.6.32-7-pve: 2.6.32-60
lvm2: 2.02.88-2pve1
clvm: 2.02.88-2pve1
corosync-pve: 1.4.1-1
openais-pve: 1.1.4-2
libqb: 0.10.1-2
redhat-cluster-pve: 3.1.8-3
resource-agents-pve: 3.9.2-3
fence-agents-pve: 3.1.7-1
pve-cluster: 1.0-23
qemu-server: 2.0-25
pve-firmware: 1.0-15
libpve-common-perl: 1.0-17
libpve-access-control: 1.0-17
libpve-storage-perl: 2.0-12
vncterm: 1.0-2
vzctl: 3.0.30-2pve1
vzprocps: 2.0.11-2
vzquota: 3.0.12-3
pve-qemu-kvm: 1.0-5
ksm-control-daemon: 1.1-1

________________________________
lyt_yudi

From: Dietmar Maurer<mailto:dietmar at proxmox.com>
Date: 2012-03-06 15:59
To: lyt_yudi<mailto:lyt_yudi at 126.com>; pve-user at pve.proxmox.com<mailto:pve-user at pve.proxmox.com>
Subject: RE: RE: [PVE-User] About backup vm Problem
Do you run latest kernel (rebooed on last kernel update)?
# uname –a
From: lyt_yudi [mailto:lyt_yudi at 126.com]<mailto:[mailto:lyt_yudi at 126.com]>
Sent: Dienstag, 06. März 2012 08:37
To: Dietmar Maurer
Subject: Re: RE: [PVE-User] About backup vm Problem

this is 103 backup log
#cat qemu-103.log
Mar 05 18:00:02 INFO: Starting Backup of VM 103 (qemu)
Mar 05 18:00:02 INFO: status = running
Mar 05 18:00:02 INFO: backup mode: snapshot
Mar 05 18:00:02 INFO: ionice priority: 7
Mar 05 18:00:03 INFO:   Logical volume "vzsnap-R510-0" created
Mar 05 18:00:03 INFO: creating archive '/var/lib/vz//dump/vzdump-qemu-103-2012_03_05-18_00_02.tar.lzo'
Mar 05 18:00:03 INFO: adding '/var/lib/vz//dump/vzdump-qemu-103-2012_03_05-18_00_02.tmp/qemu-server.conf' to archive ('qemu-server.conf')
Mar 05 18:00:03 INFO: adding '/dev/dr0vg/vzsnap-R510-0' to archive ('vm-disk-virtio0.raw')
Mar 05 18:09:33 INFO: Total bytes written: 17184066048 (28.75 MiB/s)
Mar 05 18:09:33 INFO: archive file size: 783MB
Mar 05 18:12:40 INFO: lvremove failed - trying again in 8 seconds
Mar 05 18:13:48 INFO: lvremove failed - trying again in 16 seconds
Mar 05 18:15:04 INFO: lvremove failed - trying again in 32 seconds
Mar 05 18:16:36 ERROR: command 'lvremove -f /dev/dr0vg/vzsnap-R510-0' failed: got lock timeout - aborting command
Mar 05 18:16:36 INFO: Finished Backup of VM 103 (00:16:34)

________________________________
lyt_yudi

From: Dietmar Maurer<mailto:dietmar at proxmox.com>
Date: 2012-03-06 13:51
To: lyt_yudi<mailto:lyt_yudi at 126.com>; pve-user<mailto:pve-user at pve.proxmox.com>
Subject: RE: [PVE-User] About backup vm Problem
> then the vm of the node and nodes is the down stat by web, but actually this
> nodes is normal, and the vm is normal also;

Sorry, I do not really understand the problem. Maybe you can post the backup log?

- Dietmar

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20120306/188c61a1/attachment-0014.html>


More information about the pve-user mailing list