[PVE-User] R: add wifi network interface in proxmox

Marco Vaschetto m.vaschetto at snservice.net
Mon Mar 5 10:14:01 CET 2012


Hi Lara,

 

why you try to change the name of wlan interface? I don’ t think you need to
do that.

 

If from proxmox web gui you don’ t see the wlan interface go to file
“/etc/network/interfaces” and edit it manualy.

 

For example should be like this:

 




Iface eth0 inet manual

auto wlan0

Iface wlan0 inet manual

                Wpa-ssid your-ssid-here

                Wpa-psk your-password.here

 

Iface vmbr0 inet static

                address you.address.here

                netmask your.subnet.mask.here

                gateway your.gateway.here

                bridge_ports wlan0

                bridge_stp off

                bridge_fd 0

 

Iface vmbr1 inet static

                address your.address.here

                netmask your.subnet.mask.here

                bridge_ports eth0

                bridge_stp off

                bridge_fd 0




 

Caution: I never try to configure a wlan interface whit a bridge, you can
try this configuration but I didn’ t know if i twill work.

 

You can get more information here:
http://wiki.debian.org/BridgeNetworkConnections#Setting_up_your_Bridge

 

Da: pve-user-bounces at pve.proxmox.com
[mailto:pve-user-bounces at pve.proxmox.com] Per conto di Lara S.
Inviato: lunedì 5 marzo 2012 09:27
A: pve-user at pve.proxmox.com
Oggetto: [PVE-User] add wifi network interface in proxmox

 

Hi for all!


first I want introduce me.

I install Proxmox last week and I am a beginnerDescrizione: Immagine rimossa
dal mittente.

On my server I have installed a PCI ethernet, which Proxmox has detected
automatically.
Then I added a usb wifi card, I installed the drivers necessary for it to
work.
I got up wlan0 interface and scan wireless networks, but can not see the
wifi card in my environment and do not know how to add it.

 

I have changed wlan0 to eth1 in the file
"/etc/udev/rules.d/70-persistent-net.rules"  but when I restart the computer
to apply the changes are not applied, and I get thewireless interfaces as
wlan0. 

other question is,how I can configure my wifi card to get internet and my
ethernet card for my LAN?

a greeting

thank you very much

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20120305/27450999/attachment-0014.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ~WRD000.jpg
Type: image/jpeg
Size: 823 bytes
Desc: not available
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20120305/27450999/attachment-0014.jpg>


More information about the pve-user mailing list