[PVE-User] PVE 2.1 and DRBD...

Gilberto Nunes gilberto.nunes32 at gmail.com
Sun Jul 29 04:29:15 CEST 2012


Hi friends...

As usual, I setting up a couple of box to work with DRBD...
I can create the pv and the gv...
I'm also capable of set the storage to LVM group...
Now, when I install some OS on the LVM group and when restart both nodes,
the DRBD get crash!!

That the error:

block drbd0: open("/dev/sdb5") failure with -16
...
...
...
d(r) 0: failure: Can not open backing device


And when I check LVM or DRBD, everything go to hell!....

cat /proc/drbd show that /dev/drbd0 do no connect anymore..
pvs show me /dev/block/8:21...

So, this is an error of proxmox or DRBD??

That's my configuration:

global {
        usage-count no;
 }
common {
         syncer
        {
                rate 500M;
        }
}
resource r0 {
        protocol C;
        startup {
                wfc-timeout 15;
                become-primary-on both;
        }
        net {
                allow-two-primaries;
                after-sb-0pri discard-zero-changes;
                after-sb-0pri discard-least-changes;
                after-sb-1pri discard-secondary;
       }
       on servidor-a {
                device /dev/drbd0;
                disk /dev/sdb5;
                address 10.0.0.10:7788;
                meta-disk internal;
        }
       on servidor-b {
                device /dev/drbd0;
                disk /dev/sdb5;
                address 10.0.0.20:7788;
                meta-disk internal;
        }
}

many thanks...

-- 
Gilberto Nunes


(47) 9676-7530

msn: gilbertonunesferreira at hotmail.com

msn: konnectati at konnectati.com.br

Skype: gilberto.nunes36

Skype: konnectati


*www.konnectati.com.br*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20120728/88909667/attachment-0013.html>


More information about the pve-user mailing list