[PVE-User] [URGENT] Proxmox 2.0 : Login problem after upgrade

Martin Maurer martin at proxmox.com
Fri Jan 13 13:31:18 CET 2012


Yes, vzdump is not needed (code went into other package), remove it.

In order to update, use:


Ø  aptitude update && aptitude full-upgrade

See always the announcements for new versions, including the update procedure.
E.g. http://forum.proxmox.com/threads/7855-High-Availablity-for-Proxmox-VE-2-0-beta-arrived!

Martin

From: pve-user-bounces at pve.proxmox.com [mailto:pve-user-bounces at pve.proxmox.com] On Behalf Of Guillaume MESSONNIER
Sent: Freitag, 13. Jänner 2012 12:23
To: pve-user at pve.proxmox.com
Subject: Re: [PVE-User] [URGENT] Proxmox 2.0 : Login problem after upgrade

Thanks Martin for your help !

After clearing my browser cache, same problem ! The login windows ask me for a realm with an empty combo :-(

Your right, i've pve-manager 2.0-7, not pve-manager 2.0-18. An aptitude upgrade doesn't update this package. So, i've execute an aptitude dist-upgrade :
root at proxmox:~# aptitude dist-upgrade
The following packages will be upgraded:
  pve-manager{b}
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,190 kB of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
  pve-manager: Conflicts: vzdump but 1.2.6-1 is installed.
The following actions will resolve these dependencies:

     Remove the following packages:
1)     vzdump

Accept this solution? [Y/n/q/?]

Can i remove vzdump without any problem ? What should i do ?

Kind regards,

Guillaume.

On 13/01/2012 10:34, Martin Maurer wrote:
Hi,

Reload the page, empty browser cache, see http://en.wikipedia.org/wiki/Wikipedia:Bypass_your_cache

And you did not get the latest packages, see this list:

pveversion -v
pve-manager: 2.0-18 (pve-manager/2.0/16283a5a)
running kernel: 2.6.32-6-pve
proxmox-ve-2.6.32: 2.0-55
pve-kernel-2.6.32-6-pve: 2.6.32-55
lvm2: 2.02.88-2pve1
clvm: 2.02.88-2pve1
corosync-pve: 1.4.1-1
openais-pve: 1.1.4-1
libqb: 0.6.0-1
redhat-cluster-pve: 3.1.8-3
pve-cluster: 1.0-17
qemu-server: 2.0-13
pve-firmware: 1.0-14
libpve-common-perl: 1.0-11
libpve-access-control: 1.0-5
libpve-storage-perl: 2.0-9
vncterm: 1.0-2
vzctl: 3.0.29-3pve8
vzprocps: 2.0.11-2
vzquota: 3.0.12-3
pve-qemu-kvm: 1.0-1
ksm-control-daemon: 1.1-1

Martin

From: pve-user-bounces at pve.proxmox.com<mailto:pve-user-bounces at pve.proxmox.com> [mailto:pve-user-bounces at pve.proxmox.com] On Behalf Of Guillaume MESSONNIER
Sent: Freitag, 13. Jänner 2012 08:56
To: pve-user at pve.proxmox.com<mailto:pve-user at pve.proxmox.com>
Subject: [PVE-User] [URGENT] Proxmox 2.0 : Login problem after upgrade

Hi,

This morning, i've upgrade my proxmox 2.0 server. Now, i can't log in on the web interface : a new field is appeared realm and the combo box is empty. I've only one user to log in, a Linux PAM user !

How i could modify my configuration to permit PAM user log in ?

Thanks for the help !

Guillaume.

root at proxmox:~# pveversion --verbose
pve-manager: 2.0-7 (pve-manager/2.0/de5d8ab1)
running kernel: 2.6.32-6-pve
proxmox-ve-2.6.32: 2.0-55
pve-kernel-2.6.32-6-pve: 2.6.32-55
lvm2: 2.02.88-2pve1
clvm: 2.02.88-2pve1
corosync-pve: 1.4.1-1
openais-pve: 1.1.4-1
libqb: 0.6.0-1
redhat-cluster-pve: 3.1.8-3
pve-cluster: 1.0-17
qemu-server: 2.0-13
pve-firmware: 1.0-14
libpve-common-perl: 1.0-11
libpve-access-control: 1.0-5
libpve-storage-perl: 2.0-9
vncterm: 1.0-2
vzctl: 3.0.29-3pve8
vzdump: 1.2.6-1
vzprocps: 2.0.11-2
vzquota: 3.0.12-3
pve-qemu-kvm: 1.0-1
ksm-control-daemon: 1.1-1

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20120113/5bd484e8/attachment-0014.html>


More information about the pve-user mailing list