[PVE-User] Some questions about PVE 2.0

Julien Garet julien.garet at inria.fr
Tue Jan 3 13:32:59 CET 2012

> > - Is it possible to create virtual machines through the PVE API or CLI 
> sure 
> # man qm 
> # man pvectl 
> also see: http://pve.proxmox.com/wiki/Proxmox_VE_API 
> The API allows virtual machines creation ? (I don't see it in the doc 
> : http://pve.proxmox.com/pve2-api-doc/) 

What about libvirt ? I've seen it is not used in PVE, but can it be used ? Will PVE auto discover libvirt created vms ? 

> I am having troubles with PVE 2.0 installation : 
> Installation process from ISO fails at grub installation, so I started in debug mode 
> and at the end, mounted the boot partition (+ /proc and /dev) on /target then 
> chroot to /target and update-grub + grub-install. That allowed me to boot into 
> proxmox. Where should I report that problem ? 

What error do you get exactly? 
from boostrap.log (complete file is attached): 

Setting up grub-pc (1.98+20100804-14+squeeze1) ... 

Creating config file /etc/default/grub with new version 
grub-probe: error: cannot find a device for / (is /dev mounted?). 
grub-probe: error: cannot find a device for /boot (is /dev mounted?). 
grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?). 


> Then, I tried to access to http://myserver:8006 but no daemon listens on port 
> 8006. Which one should ? Apache ? 


> Apache is not running because of a missing file in /etc/pve/local/... but there is 
> nothing in /etc/pve, after some research, it appears that it should be the mount 
> point for pmxcfs, how can I mount it ? 

# /etc/init.d/pve-cluster start 

/etc/init.d/pve-cluster start 
Starting pve cluster filesystem : pve-clusterfake start-stop-daemon called 
pve configuration filesystem not mounted 


> For info, when I try to do an aptitude upgrade (in case iso build wasn't up to 
> date), I get the following error (doesn't sound good ;-)) : 
> root at infrahv2:/etc# LANG=C aptitude upgrade 
> The following packages will be upgraded: 
> vzctl 
> The following partially installed packages will be configured: 
> clvm fence-agents-pve libpve-access-control libpve-storage-perl proxmox-ve- 
> 2.6.32 pve-cluster pve-manager qemu-server redhat-cluster-pve 
> 1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 
> Need to get 0 B/234 kB of archives. After unpacking 0 B will be used. 
> Do you want to continue? [Y/n/?] Y 
> Reading changelogs... Done 
> (Reading database ... 27451 files and directories currently installed.) 
> Preparing to replace vzctl 3.0.29-3pve3 (using .../vzctl_3.0.29- 
> 3pve8_amd64.deb) ... 
> unable to backup existing configuration 

please remove '/etc/vz/conf.org' and try again (I assume there are no existing containers?) 
No containers yet. Solved problem for vzctl, but not the other packages. 
Everything depends directly or not from pve-cluster and pve-cluster has an error : (probably linked to the other problem) 

E: Sub-process /usr/bin/dpkg returned an error code (1) 
A package failed to install. Trying to recover: 
Setting up pve-cluster (1.0-17) ... 
invoke-rc.d: policy-rc.d denied execution of restart. 
pve configuration filesystem not mounted 

dpkg: error processing pve-cluster (--configure): 
subprocess installed post-installation script returned error exit status 2 




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20120103/9f2cc073/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bootstrap.log.tar.gz
Type: application/x-compressed-tar
Size: 8494 bytes
Desc: not available
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20120103/9f2cc073/attachment.bin>

More information about the pve-user mailing list