[PVE-User] Restoring Win2k8 R2 64bit to PVE 2.0 (-cpu host!)

Hart, Brian R. brianhart at ou.edu
Wed Apr 11 19:09:57 CEST 2012


I figured out what the issue was from experimenting further.  In 1.9, I
specified args: -cpu host in the config file manually for these VMs as
they are doing some processor intensive tasks.  I had previously tried
disabling this in the GUI in 2.0 but because I had specified it by hand in
the conf file it was still in the conf file after restoring the system.

Basically, any Windows VM I try to use -cpu host with (even if I remove it
from the conf and add it through the web interface) the VM crashes with a
BSOD on startup.  If I change the cpu to qemu64, the default, it boots up
and works fine.

Anybody seen this before?


Brian Hart

-----Original Message-----
From: Brian Hart <brianhart at ou.edu>
Date: Wed, 11 Apr 2012 16:45:39 +0000
To: Alain Péan <alain.pean at lpp.polytechnique.fr>,
"pve-user at pve.proxmox.com" <pve-user at pve.proxmox.com>
Subject: Re: [PVE-User] Restoring Win2k8 R2 64bit to PVE 2.0

>I do have isos attached to both - I have done this previously too without
>issues but I'll try.  I had also tried taking the backup image with the VM
>shut down to see if that would help.  I'll unmount the ISO's though, shut
>them down, image and restore them and see what happens and post back.
>Thanks for the suggestion!
>Brian Hart
>-----Original Message-----
>From: Alain Péan <alain.pean at lpp.polytechnique.fr>
>Date: Wed, 11 Apr 2012 18:37:31 +0200
>To: <pve-user at pve.proxmox.com>
>Subject: Re: [PVE-User] Restoring Win2k8 R2 64bit to PVE 2.0
>>Le 11/04/2012 18:15, Hart, Brian R. a écrit :
>>> Hi all,
>>> So I've been working on migrating all of our virtual machines (all KVM)
>>> proxmox 2.0.  The way I decided to do it was I loaded all of our VMs on
>>> one of our old nodes and reloading one of the systems with a clean
>>> of 2.0 while I left the VMs running on the 1.9 node.  We have a SAN on
>>> backend for shared storage which we also happen to be upgrading and
>>> replacing with a new model so its working out quite well.  I've got the
>>> 2.0 system up and to move the VMs over I do this:
>>> 1.  Schedule a backup
>>> 2.  When completed, restore image into 2.0 system on new SAN
>>> 3.  When restore finishes, shut down original VM on 1.9
>>> 4.  Startup restored VM on 2.0
>>> I've done 19 systems so far this way with zero problems.  Its been
>>> between windows VMs and Linux VMs.  The windows VMs so far have been
>>> Windows 2000 Server, a WinXP VM, and a few Windows Server 2008 and 2008
>>> systems.  No problems.
>>> Now I've got just 2 Windows VMs left to move, both 2008 R2 64 bit.  I
>>> cannot get them to work after being restored.  Once I restore them,
>>> constantly BSOD on startup and won't even let me boot the recovery mode
>>> that it offers.  I thought maybe I needed to update the virtio drivers
>>> (used both for storage and NIC) so I did that on the source and did a
>>> backup/restore and it still did the same thing.
>>> Anybody have any ideas?
>>Hi Brian,
>>Perhaps one idea : I got such problem when an iso was mounted on virtual
>>cdrom. You can test with 'qm start vmid' and see
>>what error you get. If you have such an iso mounted (virtio-win, 2008 R2
>>iso...), just unmount it on 1.9, then retry.
>>Alain Péan - LPP/CNRS
>>Attention !! :  Nouveau numéro de Telephone : 01-44-27-92-39
>>Administrateur Système/Réseau
>>Laboratoire de Physique des Plasmas - UMR 7648
>>Observatoire de Saint-Maur
>>4, av de Neptune, Bat. A
>>94100 Saint-Maur des Fossés
>>pve-user mailing list
>>pve-user at pve.proxmox.com
>pve-user mailing list
>pve-user at pve.proxmox.com

More information about the pve-user mailing list