[PVE-User] WG: KVM_AMD

Holger Ernst he at ernstdatenmedien.de
Mon Apr 30 10:25:42 CEST 2012


Hi Dean,

I once named my lvm volume 'kvm' which resulted in a device called /dev/kvm and prevented the real kvm from starting.
Just a guess...

Regards, Holger

-----Urspr√ľngliche Nachricht-----
Von: pve-user-bounces at pve.proxmox.com [mailto:pve-user-bounces at pve.proxmox.com] Im Auftrag von Dean Mumby
Gesendet: Sonntag, 29. April 2012 12:24
An: pve-user at pve.proxmox.com
Betreff: [PVE-User] KVM_AMD

Hi

I have a problem with a an AMD pc , I can install proxmox so I know it is 64bit , I have updated to the latest version 

 pveversion -v
pve-manager: 2.1-1 (pve-manager/2.1/f9b0f63a)
running kernel: 2.6.32-11-pve
proxmox-ve-2.6.32: 2.0-66
pve-kernel-2.6.32-11-pve: 2.6.32-66
lvm2: 2.02.95-1pve2
clvm: 2.02.95-1pve2
corosync-pve: 1.4.3-1
openais-pve: 1.1.4-2
libqb: 0.10.1-2
redhat-cluster-pve: 3.1.8-3
resource-agents-pve: 3.9.2-3
fence-agents-pve: 3.1.7-2
pve-cluster: 1.0-26
qemu-server: 2.0-39
pve-firmware: 1.0-15
libpve-common-perl: 1.0-27
libpve-access-control: 1.0-21
libpve-storage-perl: 2.0-18
vncterm: 1.0-2
vzctl: 3.0.30-2pve5
vzprocps: 2.0.11-2
vzquota: 3.0.12-3
pve-qemu-kvm: 1.0-9
ksm-control-daemon: 1.1-1



but I am still unable to start a kvm VM. I checked the boot process and noticed the kvm_amd module not being loaded. I googled this and found it is normally when virtualization is disabled in bios as is checked by the absence of vmx/svm in cpuinfo. None of this seems to be correct  , as you can see svm is in cpuinfo

egrep '(vmx|svm)' --color=always /proc/cpuinfo
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv


modprobe -vv kvm_amd
insmod /lib/modules/2.6.32-11-pve/kernel/arch/x86/kvm/kvm-amd.ko
FATAL: Error inserting kvm_amd (/lib/modules/2.6.32-11-pve/kernel/arch/x86/kvm/kvm-amd.ko): Operation not supported

What else can I check , the machine has been powered off , cable unplugged so its not a rebooting issue.

Thanks


---
Regards
Dean Mumby
_______________________________________________
pve-user mailing list
pve-user at pve.proxmox.com
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user









More information about the pve-user mailing list