[PVE-User] [Moosefs-users] KVM on MFS

Giovanni Toraldo me at gionn.net
Wed May 25 17:51:37 CEST 2011


Hi Richard,

On 13/05/2011 19:26, Richard Chute wrote:
> 5385  open("/mfs/pve/images/101/vm-101-disk-1.raw", 
> O_RDWR|O_DIRECT|O_CLOEXEC) = -1 EINVAL (Invalid argument)

I was wrong, I am using proxmox 1.7 with MooseFS. Today, after trying to
ugrade to 1.8, I get the same error. :(

There is probably a regression (or some conflicts with MooseFS) on one
of the latest proxmox updated packages:

[AGGIORNATO] ksm-control-daemon 1.0-4 -> 1.0-5
[AGGIORNATO] libpve-storage-perl 1.0-16 -> 1.0-17
[AGGIORNATO] proxmox-ve-2.6.32 1.7-30 -> 1.8-33
[AGGIORNATO] pve-firmware 1.0-10 -> 1.0-11
[AGGIORNATO] pve-kernel-2.6.32-4-pve 2.6.32-30 -> 2.6.32-33
[AGGIORNATO] pve-manager 1.7-11 -> 1.8-17
[AGGIORNATO] pve-qemu-kvm 0.13.0-3 -> 0.14.0-3
[AGGIORNATO] qemu-server 1.1-28 -> 1.1-30
[AGGIORNATO] vzctl 3.0.24-1pve4 -> 3.0.26-1pve4
[AGGIORNATO] vzdump 1.2-10 -> 1.2-12
[AGGIORNATO] vzprocps 2.0.11-1dso2 -> 2.0.11-2

The only thing I tried, it's to manually downgrade pve-qemu-kvm to 0.13,
but nohting changed. After, I removed proxmox, modified my sources.list
to point to pve1.7 version, and reinstall, and everything was working again.

I'm cc-ing to pve mailing list too.

Regards,

-- 
Giovanni Toraldo
http://gionn.net/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 900 bytes
Desc: OpenPGP digital signature
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20110525/0712320e/attachment-0012.sig>


More information about the pve-user mailing list