[PVE-User] VM issue when Backup over NAS,

Martin Maurer martin at proxmox.com
Tue Jun 14 16:56:28 CEST 2011


Pls provide all information about your boxes like requested below.
Martin

From: Muhammad Yousuf Khan [mailto:sirtcp at gmail.com]
Sent: Dienstag, 14. Juni 2011 16:25
To: Martin Maurer
Cc: pve-user at pve.proxmox.com
Subject: Re: [PVE-User] VM issue when Backup over NAS,

here you go

CPU BOGOMIPS:      21332.18
REGEX/SECOND:      521349
HD SIZE:           94.49 GB (/dev/mapper/pve-root)
BUFFERED READS:    25.19 MB/sec
AVERAGE SEEK TIME: 32.31 ms
FSYNCS/SECOND:     3.24
DNS EXT:           303.86 ms
DNS INT:           320.81 ms (com)

please tell me what is the ideal approach for controlling the IO delay , ISCSI or local Storage.
right now IO delay is b/w 35 to 50 percent. how can i see the per VM IO so i can manually check what is going on inside rather checking every single VM one by one


On Tue, Jun 14, 2011 at 6:30 PM, Martin Maurer <martin at proxmox.com<mailto:martin at proxmox.com>> wrote:
Looks like your storage/network is overloaded. Try reducing the vzdump bandwith (see 'man vzdump').

Also post the output of 'pveperf' from your Proxmox VE host and give details about the used storage/raid hardware (Proxmox VE host and Openfiler).

Martin

From: pve-user-bounces at pve.proxmox.com<mailto:pve-user-bounces at pve.proxmox.com> [mailto:pve-user-bounces at pve.proxmox.com<mailto:pve-user-bounces at pve.proxmox.com>] On Behalf Of Muhammad Yousuf Khan
Sent: Dienstag, 14. Juni 2011 13:49
To: pve-user at pve.proxmox.com<mailto:pve-user at pve.proxmox.com>
Subject: [PVE-User] VM issue when Backup over NAS,

Openfiler : 2.99
NAS LAN : 1GB (through put is 25% i don't know why, at least acceptable)
RAM :4gb

Proxmox : 1.8
Quadcore : 2.66
Ram : 8GB
Proxmox LAN : 1G

I am using Openfiler as a NAS box. and using NFS and ISCSI both as a storage medium. but i have noticed one thing when i backup a VM on NFS and also copy a huge file inside Running VM which is hosted on ISCSI on same openfiler box. My VM get stuck. i can move the copy window in running VM but can not close task bar or copy window. until the backup task of a VM gets finishes then copy inside VM continue and VM gets usable.

how can i over come that issue. for instance if i run backup backup of my data which is inside VM it will again HANG and thing may unavailable to users during backup which is not an option
any help?


Thanks you
MYK

_______________________________________________
pve-user mailing list
pve-user at pve.proxmox.com<mailto:pve-user at pve.proxmox.com>
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20110614/4c95d6eb/attachment-0014.html>


More information about the pve-user mailing list