[PVE-User] access from Internet to a container

Giuliano Monti Avellino giulianomontiavellino at gmail.com
Sat Jul 23 02:17:12 CEST 2011


Hi every body.

I just downloaded proxmox for about a month and a half and i have been
playing creating containers with different operating system, conecting to
internet and until here every thing is ok.
The problem arise when i try to conect to a container from the internet.
The machine where i'm working is not a final machine, this is only to take
experience.
It is attached to internet without firewall only adsl.
I want to keep access to promox which of course is in the Hardware Node.
I readed http://wiki.openvz.org/Using_NAT_for_container_with_private_IPs,
but when i apply the iptables example in the "How to provide access from
internet to a container" it simply don't work

My network:

root at satelite2:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:17:4a:f2:21
          inet6 addr: fe80::216:17ff:fe4a:f221/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:28226 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28461 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1923570 (1.8 MiB)  TX bytes:1806354 (1.7 MiB)
          Interrupt:23 Base address:0xed00

eth1      Link encap:Ethernet  HWaddr 00:01:02:36:d5:4f
          inet6 addr: fe80::201:2ff:fe36:d54f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:755 errors:0 dropped:0 overruns:0 frame:0
          TX packets:484 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:87358 (85.3 KiB)  TX bytes:95968 (93.7 KiB)
          Interrupt:16 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:560 (560.0 B)  TX bytes:560 (560.0 B)

venet0    Link encap:UNSPEC  HWaddr
00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:184 errors:0 dropped:0 overruns:0 frame:0
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:45642 (44.5 KiB)  TX bytes:21856 (21.3 KiB)

vmbr0     Link encap:Ethernet  HWaddr 00:16:17:4a:f2:21
          inet addr:190.198.xx.zz  Bcast:190.198.xx.zz  Mask:255.255.224.0
          inet6 addr: fe80::216:17ff:fe4a:f221/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:28222 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28434 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1526996 (1.4 MiB)  TX bytes:1802390 (1.7 MiB)

vmbr1     Link encap:Ethernet  HWaddr 00:01:02:36:d5:4f
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::201:2ff:fe36:d54f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:754 errors:0 dropped:0 overruns:0 frame:0
          TX packets:457 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:76724 (74.9 KiB)  TX bytes:91872 (89.7 KiB)


The containers ip are 192.168.0.101, 192.168.0.102, 192.168.0.103 and
192.168.0.104 access is for port 80

Im a newbie in all this

I will appreciate if some one help me with this please?

Giuliano Monti Avellino
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20110722/3a3604f4/attachment-0013.html>


More information about the pve-user mailing list