[PVE-User] [storage] failed to delete LVM storage

James Hammer jhammer at callone.com
Wed Mar 24 13:51:11 CET 2010

Patryk Benderz wrote:
> Hi all,
> My PVE is updated. I have created new storage in following steps:
> 1.click "Storage"
> 2.at "Storage List" drop down menu selected "Add LVM Group"
> 3.filled in "storage name"
> 4.click "Save"
> 5.New storage of type LVM and named "ISO" has apperaed.
> All looked fine until step 5. But when I try to delete or disable this
> storage, i get following error on web interface: "Error: command
> '/sbin/vgchange -aln pve' failed with exit code 5". Is it some bug or am
> I doing something wrong?

I was getting a similar error when trying to delete storage.  I don't 
remember the exact circumstances, but I believe I was running LVM 
storage on top of iSCSI.  I tried running that command on the command 
line.  It worked fine on the cluster master but failed with code 5 on 
another node.  It turned out that I did not have iSCSI setup properly on 
that node.  So that node did not have access to the LVM group.

If you run pvdisplay and vgdisplay on the related PVE server(s), is your 
volume group listed?

-- James

More information about the pve-user mailing list