[PVE-User] Using Virt-manager with Proxmox

Martin Maurer martin at proxmox.com
Wed Jul 28 09:34:00 CEST 2010


Short answer - No.
Br, Martin

From: pve-user-bounces at pve.proxmox.com [mailto:pve-user-bounces at pve.proxmox.com] On Behalf Of Venumadhav Mokkapati
Sent: Mittwoch, 28. Juli 2010 09:24
To: Martin Maurer
Cc: pve-user at pve.proxmox.com
Subject: Re: [PVE-User] Using Virt-manager with Proxmox

I've installed it manually. Will it not work even after installation?

Venu Madhav
9966771737

On Wed, Jul 28, 2010 at 12:40 PM, Martin Maurer <martin at proxmox.com<mailto:martin at proxmox.com>> wrote:
Proxmox VE does not use libvirtd, so this will never work.
Br, Martin

From: pve-user-bounces at pve.proxmox.com<mailto:pve-user-bounces at pve.proxmox.com> [mailto:pve-user-bounces at pve.proxmox.com<mailto:pve-user-bounces at pve.proxmox.com>] On Behalf Of Venumadhav Mokkapati
Sent: Mittwoch, 28. Juli 2010 09:01
To: pve-user at pve.proxmox.com<mailto:pve-user at pve.proxmox.com>
Subject: [PVE-User] Using Virt-manager with Proxmox

Hi All,
        I've proxmox installed on my machine with SME server on KVM as Guest OS. When I am trying to access the VMs remotely using Virt-manger, I am getting the below error message:

010-07-21 11:48:19,463 (error:79): Uncaught Error: Unable to open a connection to the libvirt management daemon.

Libvirt URI is: qemu+ssh://root@192.168.2.39/system<http://root@192.168.2.39/system>

Verify that:
 - The 'libvirtd' daemon has been started


Unable to open connection to hypervisor URI 'qemu+ssh://root@192.168.2.39/system<http://root@192.168.2.39/system>':
server closed connection
Traceback (most recent call last):
  File "/usr/share/virt-manager/ virtManager/connection.py", line 872, in _try_open
    None], flags)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: server closed connection

Maybe you need to install ssh-askpass in order to authenticate.

Even after installing the ssh-askpass both on the Proxmox server and on the machine on which virt-manger is running, I am getting the same error. I have also verified that libvirtd is running on both the machines.

Can some one help me in figuring out what's happening here.

Thank you,
Venu Madhav
9966771737

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20100728/b94375a0/attachment-0014.html>


More information about the pve-user mailing list