[PVE-User] BUG: VM fails to start with no error message if ISO image not found

Martin Maurer martin at proxmox.com
Tue Feb 16 14:59:19 CET 2010


> -----Original Message-----
> From: pve-user-bounces at pve.proxmox.com [mailto:pve-user-
> bounces at pve.proxmox.com] On Behalf Of Flavio Stanchina
> Sent: Dienstag, 16. Februar 2010 14:49
> To: pve-user
> Subject: [PVE-User] BUG: VM fails to start with no error message if ISO
> image not found
> 
> I was trying to start a VM, but it wouldn't start and there was no
> meaningful error message anywhere: not in the web UI, not in the Logs
> page, not in the system logs. The log just said this:
> 
>    Feb 16 10:44:41 proxmox1 pvedaemon[20261]: starting VM 103 on node 1
> (localhost)
>    Feb 16 10:44:41 proxmox1 qm[20262]: VM 103 start
>    Feb 16 10:44:41 proxmox1 pvedaemon[20261]: VM 103 start failed -
> 
> Then I realized what the problem could be. Since the ISO storage was
> becoming a mess, yesterday I renamed a few ISO images to tidy up.
> Unfortunately, that VM's CD-ROM was still pointing at the ISO image I
> used for installation, which was one of those I renamed.
> 
> If it were a production machine, I would have panicked long before I
> realized what was wrong...
> 
> I guess PVE should check if the disk images are where they're supposed
> to be, before running kvm.
> 
> I'd also try to capture the error message(s) and report them in the
> logs
> if at all possible. If an ISO (or disk) image is missing, kvm will
> print
> an error message like this:
>    qemu: could not open disk image /mnt/pve/iso/...

This is no bug, its behavior by design. The error message is already displayed on the admin GUI, see Administration/Logs/Tasks (see attached screenshot)

We think of placing these logs somewhere else (better visible), you are not the first one didnĀ“t get this.

Br, Martin


> 
> --
> Flavio Stanchina
> Informatica e Servizi
> Trento - Italy
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

-------------- next part --------------
A non-text attachment was scrubbed...
Name: log.png
Type: image/png
Size: 6465 bytes
Desc: log.png
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20100216/21f60d1b/attachment-0014.png>


More information about the pve-user mailing list