[PVE-User] Second level quotas on fs mounted inside container

Carlos Acedo carlos at pangea.org
Fri Jul 17 12:01:34 CEST 2009

Hi Dietmar,

It is already enabled, quotas on the VM root file system are working
fine, but quotas on a mounted/binded doesn't work, as an example:

# vzctl start 101
# mount -n /dev/mapper/mpath1 /var/lib/vz/root/101/mnt

then, inside the VM, quotas work as expected but not in /mnt

Is there any way to make quotas work on external file systems?

Dietmar Maurer escribió:
> You need to enable user quotas on the web interface
> Virtual Machine Configuration/Options/EnableUserQuotas
> - Dietmar
>> -----Original Message-----
>> From: pve-user-bounces at pve.proxmox.com [mailto:pve-user-
>> bounces at pve.proxmox.com] On Behalf Of Carlos Acedo
>> Sent: Donnerstag, 16. Juli 2009 14:06
>> To: pve-user at pve.proxmox.com
>> Subject: [PVE-User] Second level quotas on fs mounted inside container
>> Hi,
>> I'm trying to use second level quotas on a mounted file system inside a
>> container, I have tried all sorts of combinations, mounting with -n,
>> bind instead of mount, using --device to mount the device inside the
>> container...non of those worked
>> There are more people with the same problem:
>> http://forum.openvz.org/index.php?t=msg&goto=36384&
>> I understand it's not possible to use quotas inside containers, as they
>> use the kernel module quota_v2, but, what about second-level quotas?
>> can
>> I make it work on other filesystems inside a container?
>> Thank you in advance
>> Carlos.
>> _______________________________________________
>> pve-user mailing list
>> pve-user at pve.proxmox.com
>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

More information about the pve-user mailing list