[PVE-User] bug in vztop

Venefax venefax at gmail.com
Mon Feb 16 18:42:51 CET 2009

Actually, I had to stop using the software because when I hit 1000 calls, Asterisk blew up, and it took down the container as well, since I tried to type any command and I got “cannot allocate memory”. Posted a question to the Asterisk devel group and got this:

Venefax schrieb:

> Regarding scalability. I had an issue over the weekend when Asterisk 

> got blocked when querying the database, and the amount of open calls 

> rose to 1001, but then Asterisk froze and had to be killed with "killall asterisk". Other time I had to restart the machine.

> So there is a limit somewhere. The machine had plenty of memory 

> available, but Asterisk did not seem to use it. So I would like to 

> test any new code that breaks this barrier. I can probably hit 1000 

> calls (SIP top SIP) any time. Right now I use one asterisk as 

> distributor, no database, and several others to actually route the calls (wholesale model).


This sound like you have run out of file descriptors. Asterisk needs file descriptors for each port it opens (so having 2 SIP channels bridged, both with RTCP and video you need at least 8 file descriptors per call)





I need to make sure that all files and resources are available for Asterisk. How do I do that in a container?


From: Dietmar Maurer [mailto:dietmar at proxmox.com] 
Sent: Saturday, February 14, 2009 10:48 AM
To: Venefax; pve-user at pve.proxmox.com
Subject: RE: bug in vztop


A little bit more information would be useful, i.e. how can we reproduce the bug (command line options?)


From: Venefax [mailto:venefax at gmail.com] 
Sent: Samstag, 14. Februar 2009 03:31
To: Dietmar Maurer; pve-user at pve.proxmox.com
Subject: bug in vztop


I always get this error when I run vztop:

205 processes: 204 sleeping, 1 running, 0 zombie, 0 stopped

CPU0 states:    0.1% user   0.1% system    0.0% nice   0.0% iowait  98.0% idle

CPU1 states:    0.0% user   0.0% system    0.0% nice   0.0% iowait 100.0% idle

Floating point exception


My machine is available for inspection. I need vztop, since I decided to put all my business in this technology. My box is up2date.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20090216/5251680a/attachment.htm>

More information about the pve-user mailing list