[PVE-User] Solution to an Apache2 Subversion Server Problem

Theron T. Trout theron.trout at mellonway.com
Sat Dec 5 18:20:43 CET 2009


I just wanted to share a recent experience I had dealing with a very
strange problem I experienced with a dav_svn Subversion server running
on Apache2 under a KVM virtual machine in Proxmox.  Most importantly, I
wanted to post my solution in case anyone else gets hit by this problem.

Over a period of a couple of months, access to my Subversion server from
Windows machines using both TortoiseSVN and Cygwin command line became
progressively slower.  Things continued to work well from Linux clients.

Eventually it got to the point that I could not do updates or checkouts
from Windows machines via TortoiseSVN or Cygwin.  Linux checkouts still
worked, but became progressively slower.  This was for a very small
repository of only 8MB on the server and around 170 revisions.

Errors in the Apache2 log included these messages:

  Provider encountered an error while streaming a REPORT response.
[500, #0]
  A failure occurred while driving the update report editor  [500, #103]
  Error writing base64 data: Software caused connection abort  [500, #103]

Googling these turned up several discussions, many of them years old
that appeared to be abandoned with no solutions posted.  Of those that
included suggestions, none of them helped.

A comment that did arise several times was comments that networking
issues were the cause of such symptoms.  Watching raw network traffic
did seem to support this idea, at least from Windows clients.
Strangely, all other services, including other Apache2 web sites, seemed
to work with no apparent problems.

This solution I finally found was the following.  I changed the virtual
machine from using the e1000 virtual adapter to rtl8139.  After I
brought the server back up, checkouts and updates worked fine from all
clients, and very fast.  Linux-based checkouts were also back up to full

This problem really caused me a lot of headaches.  I hope this will be
helpful if others get struck by this problem.

I'm also curious if others have had trouble with e1000 virtual adapters.
 Are there stability problems with it, perhaps with the version of KVM
that I am running?  I've not upgrade the PVE server to the new 2.x line.

My PVE version info:
pve-manager: 1.3-1 (pve-manager/1.3/4023)
qemu-server: 1.0-14
pve-kernel: 2.6.24-11
pve-kvm: 86-3
pve-firmware: 1
vncterm: 0.9-2
vzctl: 3.0.23-1pve3
vzdump: 1.2-5
vzprocps: 2.0.11-1dso2
vzquota: 3.0.11-1

Best regards,


Theron Trout
Co-Founder & Chief Software Architect,
Mellonway LLC

800-614-MWAY (6929)

Efficiency and Results through Expertise. (TM)

The information contained in this message may be privileged,
confidential, and protected from disclosure. If you are not
the intended recipient, or an employee, or agent responsible
for delivering this message to the intended recipient, you
are hereby notified that any dissemination, distribution, or
copying of this communication is strictly prohibited. If you
have received this communication in error, please notify us
immediately by replying to the message and deleting from
your computer. Opinions, conclusions, and other information
in this message that do not relate to official Mellonway
LLC business are those of the sender and are neither given
nor endorsed by Mellonway LLC.

More information about the pve-user mailing list