[PVE-User] Debian security updates on PVE 1.3

Jeff Saxe JSaxe at briworks.com
Wed Aug 26 15:51:29 CEST 2009


Yes, when I was hacking around with DRBD on Proxmox 1.3, which does  
come with DRBD 8.3.1 embedded in the kernel, I initially just did "apt- 
get install drbd8-utils", but that installed an older 8.0.14 version  
of the CLI tools. It seemed to start working, but when I tried to  
actually sync up two machines, one of them errored out and they  
refused to start the sync process. I finally went to the Debian  
package repository and found the "lenny-backports" section...

http://packages.debian.org/lenny-backports/drbd8-utils

...which has the file I needed...

drbd8-utils_8.3.2-1~bpo50+1_amd64.deb

After downloading you have to "dpkg" to install it manually. Each time  
I run a CLI command it whines at me that the 8.3.2 utils are now  
actually newer than the 8.3.1 kernel, and they should match, but it  
still works.

Remember that just because DRBD is in the kernel does not mean that a  
DRBD-replicated piece of VM storage is trivial to use in Proxmox as of  
version 1.3; it's not in the GUI, and the two machines don't have a  
good idea of who is primary and who is secondary, and the .conf files  
need to be either moved to the DRBD portion or manually copied to both  
servers, etc... this is a totally out-of-the-norm hack. Try to  
experiment with it, but also try to watch for what Martin and Dietmar  
will bring out in version 1.4.

-- JeffS



On Aug 26, 2009, at 6:47 AM, Martin Maurer wrote:

>> -----Original Message-----
>> From: pve-user-bounces at pve.proxmox.com [mailto:pve-user-
>> bounces at pve.proxmox.com] On Behalf Of Peter Burkard
>> Sent: Mittwoch, 26. August 2009 11:31
>> To: pve-user at pve.proxmox.com
>> Subject: [PVE-User] Debian security updates on PVE 1.3
>>
>>
>> Hi.
>>
>> I'm trying to add new software (DRDB) from the official repos and
>> "aptitude" tells me that there are some security updates available.
>> Now I wonder if there are any don'ts on PVE 1.3?
>>
>> Anyone there with an idea?
>
> Pls provide details - which apt sources do you use and which updates  
> are missing?
>
> Proxmox VE has DRBD 8.3.1 included, so you need the drbd8-utils in  
> the same version to manage.
>
> Br, Martin
>
>>
>> Regards / Mit freundlichen Grüßen
>>
>> Peter Burkard
>>
>> ABB AG
>> ABB/PTSP-O12
>> Kallstadter Str. 1
>> D-68309-Mannheim
>>
>> Phone: +49 621 381 2012
>> Mobile: +49 621 381 2013
>> email: peter.burkard at de.abb.com
>
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20090826/85b7c3fa/attachment-0014.html>


More information about the pve-user mailing list