[PVE-User] Migration Bug

Dietmar Maurer dietmar at proxmox.com
Wed Nov 5 18:33:06 CET 2008


we use "ssh -t -t" to allocate a pty (that way we can abort a remote
process)

 

That causese the : Inappropriate ioctl for device error - you can ignore
it.

 

- Dietmar

 

From: pve-user-bounces at pve.proxmox.com
[mailto:pve-user-bounces at pve.proxmox.com] On Behalf Of Andrew
Niemantsverdriet
Sent: Mittwoch, 05. November 2008 18:23
To: proxmoxve
Subject: Re: [PVE-User] Migration Bug

 

This seems to have fixed it self after a reboot and changing the other
bridge interface that I added to not have an IP. Maybe the command was
going out the wrong interface causing the key exchange to fail?

On Wed, Nov 5, 2008 at 9:42 AM, Andrew Niemantsverdriet
<andrew at rocky.edu> wrote:

When trying to migrate a KVM or OpenVZ machine between two slaves it
fails both online and offline migrations.

The error given is this:

/usr/bin/ssh -t -t -n -o BatchMode=yes $HOST1 /usr/sbin/qmigrate $HOST2
106
tcgetattr: Inappropriate ioctl for device
starting migration of VM 106 to host '$HOST2' 
Can't connect to destination address using public key 
Connection to $HOST1 closed. 
VM 106 migration failed - 

HOST1 is the machine that VM currently resides on
HOST2 is the machine that I am trying to migrate to

They both are slave nodes in a cluster.

Also the tcgetattr: Inappropriate ioctl for device message has been
appearing a lot I don't know why but it does appear to cause any issues.

-- 
_
/-\ ndrew Niemantsverdriet
Academic Computing
Alden 007
(406) 238-7360
andrew at rocky.edu




-- 
_
/-\ ndrew Niemantsverdriet
Academic Computing
Alden 007
(406) 238-7360
andrew at rocky.edu

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-user/attachments/20081105/2a7d1766/attachment-0014.html>


More information about the pve-user mailing list