[pve-devel] [PATCH qemu-server v2 5/8] machine: add S3/S4 power state properties
Fiona Ebner
f.ebner at proxmox.com
Fri Apr 4 13:53:04 CEST 2025
Am 07.03.25 um 15:44 schrieb Dominik Csapak:
> So users can disable them (they're enabled by default in QEMU)
>
> Signed-off-by: Dominik Csapak <d.csapak at proxmox.com>
> ---
> changes from v1:
> * rework the method with suggestions from fiona
> * change way we add flags because we don't have globalflags anymore
>
> PVE/QemuServer.pm | 4 ++++
> PVE/QemuServer/Machine.pm | 37 +++++++++++++++++++++++++++++++++++++
> 2 files changed, 41 insertions(+)
>
> diff --git a/PVE/QemuServer.pm b/PVE/QemuServer.pm
> index 1da7e9a1..1aaee8d0 100644
> --- a/PVE/QemuServer.pm
> +++ b/PVE/QemuServer.pm
> @@ -3975,6 +3975,10 @@ sub config_to_command {
> push @$machineFlags, 'accel=tcg';
> }
>
> + if (my $options = PVE::QemuServer::Machine::check_and_set_power_state_flags($machine_conf)) {
> + push $cmd->@*, $options->@*;
> + }
Nit: I think $options is too generic of a variable name. I'd rather have
the function call not inside the if and a nicer name like
$power_state_flags. Then you can check the variable in the if (or
post-if ;))
> +
> push @$machineFlags, 'smm=off' if should_disable_smm($conf, $vga, $machine_type);
>
> my $machine_type_min = $machine_type;
> diff --git a/PVE/QemuServer/Machine.pm b/PVE/QemuServer/Machine.pm
> index a5962443..d2349d4d 100644
> --- a/PVE/QemuServer/Machine.pm
> +++ b/PVE/QemuServer/Machine.pm
> @@ -31,6 +31,16 @@ my $machine_fmt = {
> enum => ['intel', 'virtio'],
> optional => 1,
> },
> + 'enable-s3' => {
> + type => 'boolean',
> + description => "Enables S3 power state. Defaults to true.",
> + optional => 1,
> + },
> + 'enable-s4' => {
> + type => 'boolean',
> + description => "Enables S4 power state. Defaults to true.",
> + optional => 1,
> + },
> };
>
> PVE::JSONSchema::register_format('pve-qemu-machine-fmt', $machine_fmt);
> @@ -284,4 +294,31 @@ sub check_and_pin_machine_string {
> return print_machine($machine_conf);
> }
>
> +# disable s3/s4 by default for 9.2+pve1 machine types
Nit: this comment line belongs to the next patch.
> +# returns a list of cmdline options for qemu or undef
Nit: actually an array ref, not a list.
> +sub check_and_set_power_state_flags {
Should be renamed as it doesn't set anything. Maybe "get_power_state_flags"?
> + my ($machine_conf) = @_;
> +
> + my $object = $machine_conf->{type} && ($machine_conf->{type} =~ m/q35/) ? "ICH9-LPC" : "PIIX4_PM";
> +
> + my $s3 = $machine_conf->{'enable-s3'} // 1;
> + my $s4 = $machine_conf->{'enable-s4'} // 1;
> +
> + my $options = [];
> +
> + # they're enabled by default in QEMU, so only add the flags to disable them
> + if (!$s3) {
> + push $options->@*, '-global', "${object}.disable_s3=1";
> + }
> + if (!$s4) {
> + push $options->@*, '-global', "${object}.disable_s4=1";
> + }
> +
> + if (scalar($options->@*)) {
> + return $options;
> + }
> +
> + return;
> +}
> +
> 1;
More information about the pve-devel
mailing list