[pve-devel] applied-series: [PATCH installer v4 0/4] add check/rename for already-existing ZFS rpool

Thomas Lamprecht t.lamprecht at proxmox.com
Tue Jul 16 17:59:55 CEST 2024


Am 16/07/2024 um 10:18 schrieb Christoph Heiss:
> Pretty straight forward overall, implements a check for an existing
> `rpool` on the system and ask the user whether they would like to rename
> it, much in the same way as it works for VGs already.
> 
> Without this, the installer would silently create a second (and thus
> conflicting) `rpool` and cause a boot failure after the installation,
> since it does not know which pool to import exactly.
> 
> v1: https://lists.proxmox.com/pipermail/pve-devel/2024-May/063874.html
> v2: https://lists.proxmox.com/pipermail/pve-devel/2024-July/064619.html
> v3: https://lists.proxmox.com/pipermail/pve-devel/2024-July/064635.html
> 
> Notable changes v3 -> v4:
>   * rebased on latest master
>   * rename $response_ok -> $do_rename for clarity, as suggested by Aaron
> 
> Notable changes v2 -> v3:
>   * make low-level option lvm_auto_rename more generic
>   * skip rename prompt in auto-install mode
> 
> Notable changes v1 -> v2:
>   * incorporated Aarons suggestions from v1
>   * rewrote tests to use a pre-defined input instead
>   * moved pool renaming to own subroutine
>   * documented all new subroutines
>   * split out tests into own patch
> 
> Christoph Heiss (4):
>   proxmox: add zfs module for retrieving importable zpool info
>   test: add test cases for new zfs module
>   install: config: rename option lvm_auto_rename ->
>     existing_storage_auto_rename
>   low-level: install: check for already-existing `rpool` on install
> 
>  Proxmox/Install.pm                            |  41 ++++++-
>  Proxmox/Install/Config.pm                     |   6 +-
>  Proxmox/Makefile                              |   1 +
>  Proxmox/Sys/ZFS.pm                            | 109 ++++++++++++++++++
>  proxmox-auto-installer/src/utils.rs           |   2 +-
>  .../resources/parse_answer/disk_match.json    |   2 +-
>  .../parse_answer/disk_match_all.json          |   2 +-
>  .../parse_answer/disk_match_any.json          |   2 +-
>  .../tests/resources/parse_answer/minimal.json |   2 +-
>  .../resources/parse_answer/nic_matching.json  |   2 +-
>  .../resources/parse_answer/specific_nic.json  |   2 +-
>  .../tests/resources/parse_answer/zfs.json     |   2 +-
>  proxmox-installer-common/src/setup.rs         |   2 +-
>  proxmox-tui-installer/src/setup.rs            |   2 +-
>  test/Makefile                                 |   7 +-
>  test/zfs-get-pool-list.pl                     |  57 +++++++++
>  16 files changed, 223 insertions(+), 18 deletions(-)
>  create mode 100644 Proxmox/Sys/ZFS.pm
>  create mode 100755 test/zfs-get-pool-list.pl
> 


applied series, thanks!

But I took the liberty to squash in the second patch adding tests into the
first one, while doing preparatory work can sometimes be OK, I'd not split
that up too much. Also mentioned for what this preparatory work is planned
to be used, as such context can be quite helpful when checking out single
commits that don't do anything on their own.




More information about the pve-devel mailing list