[pve-devel] [RFC manager 1/1] ui: lvm: expose saferemove setting
Fabian Grünbichler
f.gruenbichler at proxmox.com
Tue Jan 9 10:49:05 CET 2024
On December 7, 2023 5:10 pm, Fiona Ebner wrote:
> It can be security-relevant in some environments. The LVM storage
> documentation can be reached via the "Help" button and contains a few
> more details.
>
> Signed-off-by: Fiona Ebner <f.ebner at proxmox.com>
> ---
> www/manager6/storage/LVMEdit.js | 10 ++++++++++
> 1 file changed, 10 insertions(+)
>
> diff --git a/www/manager6/storage/LVMEdit.js b/www/manager6/storage/LVMEdit.js
> index fde302fc..37d3c6ef 100644
> --- a/www/manager6/storage/LVMEdit.js
> +++ b/www/manager6/storage/LVMEdit.js
> @@ -228,5 +228,15 @@ Ext.define('PVE.storage.LVMInputPanel', {
> uncheckedValue: 0,
> fieldLabel: gettext('Shared'),
> },
> + {
> + xtype: 'proxmoxcheckbox',
> + name: 'saferemove',
> + uncheckedValue: 0,
> + fieldLabel: gettext('Safe Remove'),
> + autoEl: {
> + tag: 'div',
> + 'data-qtip': gettext("Zero-out data when removing LVs"),
IMHO the option is a bit misnamed unfortunately ("Safe Remove" sounds
like something I'd almost always enable - it's "safe" after all ;)).
I am not sure how many users read the tooltips, one possible alternative
would be to make the label sound more dangerous (or rather, use
something there that implies it has a cost), and move the option name
into the tooltip? maybe something like "Wipe removed volumes" could
work?
> + },
> + },
> ],
> });
> --
> 2.39.2
>
>
>
> _______________________________________________
> pve-devel mailing list
> pve-devel at lists.proxmox.com
> https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-devel
>
>
>
More information about the pve-devel
mailing list