[pve-devel] [PATCH storage v4 3/4] pbs: Extraxt check_datastore_exists from activate_storage
Fiona Ebner
f.ebner at proxmox.com
Fri Feb 16 16:56:43 CET 2024
Am 27.11.23 um 12:40 schrieb Philipp Hufnagl:
> Parts contained in activate_storage are needed to be run to fix #5008,
> however, implementing a namespace check there would cause unneeded
> overhead.
>
> Therefore, this patch extracts the method check_datastore_exists from
> activate storage.
>
> Signed-off-by: Philipp Hufnagl <p.hufnagl at proxmox.com>
> ---
> src/PVE/Storage/PBSPlugin.pm | 20 ++++++++++++--------
> 1 file changed, 12 insertions(+), 8 deletions(-)
>
> diff --git a/src/PVE/Storage/PBSPlugin.pm b/src/PVE/Storage/PBSPlugin.pm
> index b4d7914..3e0e155 100644
> --- a/src/PVE/Storage/PBSPlugin.pm
> +++ b/src/PVE/Storage/PBSPlugin.pm
> @@ -817,17 +817,13 @@ sub scan_datastores {
>
> return $response;
> }
> -
Style nit: there is no blank line between the subs anymore
> -sub activate_storage {
> - my ($class, $storeid, $scfg, $cache) = @_;
> -
> - my $password = pbs_get_password($scfg, $storeid);
> -
> - my $datastores = eval { scan_datastores($scfg, $password) };
> - die "$storeid: $@" if $@;
> +sub check_datastore_exists {
> + my ($class, $storeid, $scfg, $password, $conn) = @_;
>
> my $datastore = $scfg->{datastore};
>
> + my $datastores = eval { scan_datastores($scfg, $password, $conn) };
> + die "$storeid: $@" if $@;
> for my $ds (@$datastores) {
> if ($ds->{store} eq $datastore) {
> return 1;
> @@ -837,6 +833,14 @@ sub activate_storage {
> die "$storeid: Cannot find datastore '$datastore', check permissions and existence!\n";
> }
>
Since the function dies, it should rather be named assert_ and not check_
More information about the pve-devel
mailing list