[pve-devel] [PATCH v2 qemu-server 2/2] Rename vm_is_paused to vm_is_frozen

Fiona Ebner f.ebner at proxmox.com
Mon Oct 9 13:11:09 CEST 2023

Am 25.08.23 um 14:18 schrieb Filip Schauer:
> Rename vm_is_paused to vm_is_frozen to avoid confusion with the "paused"
> runstate.

I know I suggested renaming the function, but with 'frozen' there is
potential for new confusion with fsfreeze, especially with the
user-facing warnings/errors. It's also that 'paused' sounds nicer to
users here IMHO.

Maybe we can call it vcpus_(are_)paused and keep the user-facing
messages the same? Or we can just keep the current name. Right now,
there is no case where we need to distinguish between having runstate
'paused' and the return value of vm_is_paused().

More information about the pve-devel mailing list