[pve-devel] [PATCH storage v3 0/4] pbs: fix #5008: Prevent adding pbs storage with invalid namespace

Philipp Hufnagl p.hufnagl at proxmox.com
Tue Nov 21 14:12:47 CET 2023

On 11/21/23 13:16, Christian Ebner wrote:
>> On 16.11.2023 11:35 CET Philipp Hufnagl <p.hufnagl at proxmox.com> wrote:
>> Currently, when adding a PBS storage with a namespace that does not
>> exist, the storage gets added normally, but browsing/using it only
>> returns a cryptic error message.
>> This change checks if the namespace entered when adding is valid and
>> prompts an error if it is not. If no namespace is provided, the storage
>> will be added without error.
>> This is done by adding code to check if the namespace exists and call it
>> as well as existing code to check if a datastore exists on the add and
>> update hooks of the PBS datastore.
>> Signed-off-by: Philipp Hufnagl <p.hufnagl at proxmox.com>
>> ---
>> Changes since v2:
>>  * Typos
>>  * reuse connecton on one more place previously fortotten
>>  * simplify syntax
>> Changes since v1:
>>  * do not add any overhead to activate_storage calls
>>  * splits code from activate_storage so parts of it can be reused
>>  * adds new methods to check namespaces
>>  * calls checks on add/update hooks
>> Philipp Hufnagl (4):
>>   pbs: Move pbs_api_connect earlyer in the code
>>   pbs: Make it possible to reuse PBS connection for datastore API call
>>   pbs: Extraxt check_datastore_exists from activate_storage
>>   pbs: fix #5008: Check if datastore and namespace is valid on add- and
>>     update hooks
>>  src/PVE/Storage/PBSPlugin.pm | 122 ++++++++++++++++++++++++-----------
>>  1 file changed, 84 insertions(+), 38 deletions(-)
>> -- 
>> 2.39.2
> Something is still broken, while testing with your patches applied I am not able to edit an existing PBS storage backend.
> When I try to e.g. disable the storage via the WebUI I get the following error:
> `update storage failed: PBS-local: Cannot find datastore '', check permissions and existence! (500)`
> Without your patches applied everything works as expected again.
> Cheers,
> Chris

Hmmm...  thats very curios. I tried that on my end and it worked fine.

What datastore did you try to delete? Did you have a valid
configuration for it?

More information about the pve-devel mailing list