[pve-devel] [PATCH v2 container 3/4] lxc: Add `link-down` config to allow setting interfaces as disconnected

Thomas Lamprecht t.lamprecht at proxmox.com
Fri Feb 17 17:38:57 CET 2023

Am 17/02/2023 um 15:51 schrieb Wolfgang Bumiller:
>>  * Rename option to kebap-case
> Sorry I missed that when Thomas replied to the v1.
> This is a case where the property already exists in the VM api, so
> better reuse the snake_case version here. @Thomas?

I assumed that, that's why I asked if keeping it that way would help to reuse some
code infra; not sure about how useful it is to keep it for API consumers to keep it
the same as in a quite different API end point, but I see where you come from and don't
insist for going with snake-case, so if you think using the same style here has benefits.
we can ignore the guidance that new params should always use kebab-case.

but as said off-list, a big s/_/-/ (and same for our camelCase usages -.-) for PVE 8.0
seems long overdue; then we can also add some style asserts in the api schema verifier
to avoid reintroducing those things.

More information about the pve-devel mailing list