[pve-devel] [PATCH manager/proxmox-acme/pwt 0/3] fix #3536 add http proxy support for acme

Stoiko Ivanov s.ivanov at proxmox.com
Tue Nov 9 17:36:27 CET 2021


the individual patches are mostly short and hopefully self-explaining

The change in the gui to reuse the components from proxmox-widget-toolkit is
a result of preparing the series also for pmg and pbs and noticing that this
at least is an area, where reuse seems easy.

Tested on my setup with a publicly exposed powerdns-plugin and let's encrypt
(mostly staging)

proxmox-acme:
Stoiko Ivanov (2):
  add support for proxies
  dns-challenge: add 'use-proxy' property

 src/PVE/ACME.pm              |  6 ++++++
 src/PVE/ACME/DNSChallenge.pm | 10 +++++++++-
 2 files changed, 15 insertions(+), 1 deletion(-)

proxmox-widget-toolkit:
Stoiko Ivanov (1):
  acmeplugin: add use-proxy checkbox

 src/window/ACMEPluginEdit.js | 8 ++++++++
 1 file changed, 8 insertions(+)

pve-manager:
Stoiko Ivanov (3):
  api: acme: set http_proxy if configured in datacenter.cfg
  api: acme: dns-plugin: conditionally pass proxy to acme.sh wrapper
  gui: use acme plugin editor from proxmox-widget-toolkit

 PVE/API2/ACME.pm                   |  20 +++
 PVE/API2/ACMEAccount.pm            |  17 +++
 www/manager6/Makefile              |   1 -
 www/manager6/dc/ACMEClusterView.js |  13 +-
 www/manager6/dc/ACMEPluginEdit.js  | 223 -----------------------------
 5 files changed, 47 insertions(+), 227 deletions(-)
 delete mode 100644 www/manager6/dc/ACMEPluginEdit.js

-- 
2.30.2





More information about the pve-devel mailing list