[pve-devel] applied: [PATCH manager 1/4] ui: ceph installer: make replicas & minreplicas fields dependent

Thomas Lamprecht t.lamprecht at proxmox.com
Thu Mar 28 16:21:07 CET 2019


On 3/28/19 12:16 PM, Tim Marx wrote:
> Signed-off-by: Tim Marx <t.marx at proxmox.com>
> ---
>  www/manager6/ceph/CephInstallWizard.js | 32 +++++++++++++++++++++++++-------
>  1 file changed, 25 insertions(+), 7 deletions(-)
> 

applied, with a followup removing the allowBlank logic, was a bit strange,
I also trigger now an explicit validate if the min_size fields maxValue changes,
this is IMO an extjs bug, because as soon as the limits of a numberfield change
a validate change _must_ be triggered, else one cannot guarantee that the
current value is still valid. We could override the Ext.form.field.Number's
setMaxValue and setMinValue with this, would allow us to save some code in
general where numberfields max/min value depend on other entries (e.g., qemu's
memory edit)



More information about the pve-devel mailing list