[pve-devel] applied: [PATCH common] d/control: add missing dependencies

Wolfgang Bumiller w.bumiller at proxmox.com
Mon Feb 11 10:59:59 CET 2019


applied

On Fri, Feb 08, 2019 at 09:57:07PM +0100, Fabian Gr├╝nbichler wrote:
> used by the ACME standalone challenge.
> 
> these were previously already depended on by pve-manager, where they were
> recently removed - exposing the fact they are in fact required by
> libpve-common-perl.
> 
> Signed-off-by: Fabian Gr├╝nbichler <f.gruenbichler at proxmox.com>
> ---
> Notes:
>     even if we might change the standalone HTTP implementation soonish - this
>     breaks fresh installs on a minimal debian system (e.g., via ansible).
> 
>  debian/control | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/debian/control b/debian/control
> index 79f2b7b..c895f6f 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -20,6 +20,8 @@ Depends: libclone-perl,
>           libcrypt-openssl-rsa-perl,
>           libdevel-cycle-perl,
>           libfilesys-df-perl,
> +         libhttp-daemon-perl,
> +         libhttp-message-perl,
>           libio-stringy-perl,
>           libjson-perl,
>           liblinux-inotify2-perl,
> -- 
> 2.20.1



More information about the pve-devel mailing list