[pve-devel] [PATCH pve-libspice-server 0/4] upgrade to 0.14.1

Thomas Lamprecht t.lamprecht at proxmox.com
Wed Sep 26 07:32:15 CEST 2018


On 9/25/18 1:38 PM, Dominik Csapak wrote:
> On 9/25/18 12:54 PM, Thomas Lamprecht wrote:
>> I get the following build/test error:
>>
>> ===============================================
>>     spice 0.14.1: server/tests/test-suite.log
>> ===============================================
>>
>> # TOTAL: 16
>> # PASS:  15
>> # SKIP:  0
>> # XFAIL: 0
>> # FAIL:  1
>> # XPASS: 0
>> # ERROR: 0
>>
>> .. contents:: :depth: 2
>>
>> FAIL: test-vdagent
>> ==================
>>
>> /server/vdagent/agent-to-server: TESTER: listening on port 5912 (unsecure)
>> OK
>> /server/vdagent/duplicate-removal: TESTER: listening on port 5912 (unsecure)
>> OK
>> /server/vdagent/multiple-vmc-devices:
>> (./test-vdagent:153335): Spice-WARNING **: reds.c:2570:reds_init_socket: binding socket to :5912 failed
>>
>> (./test-vdagent:153335): Spice-WARNING **: reds.c:3382:do_spice_init: Failed to open SPICE sockets
>> XXX [reds.c:3382:do_spice_init: Failed to open SPICE sockets]
>> FAIL test-vdagent (exit status: 133)
>>
>> did not investigated further, am I still doing something wrong?
>>
> 
> mhmm works here, how does your build environment look like?

I could reproduce what you said off-list to me, i.e., there seemingly is a race
in the test process about binding to the port...

Ideally we (you? :-) ) report this upstream, but for those few times we build
it we can just use it as is here, IMO.




More information about the pve-devel mailing list