[pve-devel] [PATCH pve-libspice-server 0/4] upgrade to 0.14.1

Thomas Lamprecht t.lamprecht at proxmox.com
Tue Sep 25 12:54:30 CEST 2018


On 9/25/18 12:16 PM, Dominik Csapak wrote:
> this series upgrades pve-libspice-server to 0.14.1
> replaces CELT with libopus
> adds liblz4 as dev dependency
> increase compat level
> 
> after that we can do a make download and replace the tar.bz2
> and we can remove the celt.tar.gz
> 
> for this package to work we need the package
> libspice-protocol-dev > 0.12.13
> 
> either we try to upgrade our existing package
> or we backport the one from sid/buster (which is 0.12.14-1 and has
> no dependecies)
> 
> after this is built, we need to rebuild pve-qemu-kvm and spiceterm
> with the new -dev packages
> 
> Dominik Csapak (4):
>   upgrade to 0.14.1
>   replace CELT with libopus
>   add liblz4 as dev dependency
>   increase debian/compat to level 10
> 
>  Makefile                                           | 11 +----
>  debian/compat                                      |  2 +-
>  debian/control                                     |  2 +
>  .../patches/CVE-2016-9577-and-CVE-2016-9578.patch  | 54 ----------------------
>  debian/patches/allow-to-set-sasl-callbacks.patch   | 10 ++--
>  debian/patches/series                              |  1 -
>  debian/pve-libspice-server-dev.install             |  1 -
>  debian/rules                                       |  4 +-
>  8 files changed, 12 insertions(+), 73 deletions(-)
>  delete mode 100644 debian/patches/CVE-2016-9577-and-CVE-2016-9578.patch
> 

I get the following build/test error:

===============================================
   spice 0.14.1: server/tests/test-suite.log
===============================================

# TOTAL: 16
# PASS:  15
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: test-vdagent
==================

/server/vdagent/agent-to-server: TESTER: listening on port 5912 (unsecure)
OK
/server/vdagent/duplicate-removal: TESTER: listening on port 5912 (unsecure)
OK
/server/vdagent/multiple-vmc-devices:
(./test-vdagent:153335): Spice-WARNING **: reds.c:2570:reds_init_socket: binding socket to :5912 failed

(./test-vdagent:153335): Spice-WARNING **: reds.c:3382:do_spice_init: Failed to open SPICE sockets
XXX [reds.c:3382:do_spice_init: Failed to open SPICE sockets]
FAIL test-vdagent (exit status: 133)

did not investigated further, am I still doing something wrong?



More information about the pve-devel mailing list