[pve-devel] [PATCH pve-libspice-server 0/4] upgrade to 0.14.1

Dominik Csapak d.csapak at proxmox.com
Tue Sep 25 12:16:18 CEST 2018


this series upgrades pve-libspice-server to 0.14.1
replaces CELT with libopus
adds liblz4 as dev dependency
increase compat level

after that we can do a make download and replace the tar.bz2
and we can remove the celt.tar.gz

for this package to work we need the package
libspice-protocol-dev > 0.12.13

either we try to upgrade our existing package
or we backport the one from sid/buster (which is 0.12.14-1 and has
no dependecies)

after this is built, we need to rebuild pve-qemu-kvm and spiceterm
with the new -dev packages

Dominik Csapak (4):
  upgrade to 0.14.1
  replace CELT with libopus
  add liblz4 as dev dependency
  increase debian/compat to level 10

 Makefile                                           | 11 +----
 debian/compat                                      |  2 +-
 debian/control                                     |  2 +
 .../patches/CVE-2016-9577-and-CVE-2016-9578.patch  | 54 ----------------------
 debian/patches/allow-to-set-sasl-callbacks.patch   | 10 ++--
 debian/patches/series                              |  1 -
 debian/pve-libspice-server-dev.install             |  1 -
 debian/rules                                       |  4 +-
 8 files changed, 12 insertions(+), 73 deletions(-)
 delete mode 100644 debian/patches/CVE-2016-9577-and-CVE-2016-9578.patch

-- 
2.11.0




More information about the pve-devel mailing list