[pve-devel] Please help: beginner trying to compile Proxmox kernel 4.15

The Anh Tran trtheanh at gmail.com
Tue Sep 25 10:52:30 CEST 2018


Dear Fabian,


On 9/24/2018 11:09 PM, Fabian Grünbichler wrote:
> if you don't have a source for that module, (reliably) using it will not
> be possible unless the vendor compiles it for you for every PVE kernel
> update that changes the ABI.
>
> even if we would enable force loading, there is absolutely no guarantee
> that the module will actually work - (kernel) ABIs exist for a reason,
> and our kernel and Ubuntu's are very close, but not ABI-compatible.
>
> _______________________________________________
> pve-devel mailing list
> pve-devel at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel

I'm stress-testing scini.ko on force-load-enabled kernel now:
add/remove volume, change vol size, connect/disconnect devices, migrate 
VMs ...
while top VMs issue heavy random readwrite IOPS.

Before make run, i did git-checkout revision which as close as possible 
to Ubuntu's release:
Ubuntu Git: 4.15.0-33.36~16.04.1 Ubuntu-hwe-4.15.0-33.36_16.04.1    4.15.18
Proxmox Git: 2018-08-24  bump version to 4.15.18-22
https://git.proxmox.com/?p=pve-kernel.git;a=commit;h=2b76f08c16c9e48fce96c8d5d7346d8dd2b3fe4a

Doing a diff on 2 kernel's abi files, and on 2 kernel's config files, i 
read that there are major differences on NVME, BRIDGE_NETFILTER being 
moved from modules to internal.
Other things seem the same.

Hope this sdc works well, better than nothing works.

Thank you for spending your time support me.
Best regards.

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus



More information about the pve-devel mailing list