[pve-devel] Use of uninitialized value in string eq at /usr/share/perl5/PVE/CLIFormatter.pm line 390.

Eduard Ahmatgareev e.ahmatgareev at gmail.com
Mon Sep 24 20:43:02 CEST 2018


Hi All,

Does anybody has issue with CLI on latest version?

root at cluster-13-1:~# pvesh get /access/users --output-format json-pretty
[
   {
      "enable" : 1,
      "expire" : 0,
      "userid" : "apicontrol1 at pve"
   },
   {
      "email" : "apicontrol at admin.ru",
      "enable" : 1,
      "expire" : 0,
      "firstname" : "apicontrol",
      "lastname" : "apicontrol",
      "userid" : "apicontrol at pve"
   },
]
root at cluster-13-1:~#

root at cluster-13-1:~# pvesh get /access/users/apicontrol1 at pve
--output-format json-pretty
Use of uninitialized value in string eq at
/usr/share/perl5/PVE/CLIFormatter.pm line 390.
{
   "enable" : 1,
   "expire" : 0,
   "groups" : [
      "api"
   ]
}
root at cluster-13-1:~#

It looks like as the mistake in code.

root at cluster-13-1:~# pveversion
pve-manager/5.2-9/4b30e8f9 (running kernel: 4.15.18-4-pve)
root at cluster-13-1:~# pveversion --verbose
proxmox-ve: 5.2-2 (running kernel: 4.15.18-4-pve)
pve-manager: 5.2-9 (running version: 5.2-9/4b30e8f9)
pve-kernel-4.15: 5.2-7
pve-kernel-4.15.18-4-pve: 4.15.18-23
pve-kernel-4.15.17-1-pve: 4.15.17-9
corosync: 2.4.2-pve5
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.0-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-38
libpve-guest-common-perl: 2.0-17
libpve-http-server-perl: 2.0-10
libpve-storage-perl: 5.0-28
libqb0: 1.0.1-1
lvm2: 2.02.168-pve6
lxc-pve: 3.0.2+pve1-2
lxcfs: 3.0.0-1
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-20
pve-cluster: 5.0-30
pve-container: 2.0-27
pve-docs: 5.2-8
pve-firewall: 3.0-14
pve-firmware: 2.0-5
pve-ha-manager: 2.0-5
pve-i18n: 1.0-6
pve-libspice-server1: 0.12.8-3
pve-qemu-kvm: 2.11.2-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-34
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.9-pve1~bpo9
root at cluster-13-1:~#


root at cluster-13-1:~# dpkg -S /usr/share/perl5/PVE/CLIFormatter.pm
libpve-common-perl: /usr/share/perl5/PVE/CLIFormatter.pm
root at cluster-13-1:~#

Previous version:
libpve-common-perl: 5.0-35
works without this issue.


More information about the pve-devel mailing list