[pve-devel] [PATCH http-server 0/2] Replace own Websocket parser with Protocol::Websocket.

René Jochum rene at jochums.at
Mon May 21 17:00:49 CEST 2018


It needs "libprotocol-websocket-perl" installed, currently
not available via Debian repos. I got a Debian package for that.

https://git.lxch.eu/pcdummy/libprotocol-websocket-perl/-/jobs/75/artifacts/browse

This partially fixes NoVNC over nginx and implements
more Websocket protocols.

I tested:
  NoVNC with UTF-8
  xterm.js with UTF-8
  pventer
  Run cacafire in all 3 a long time.

René Jochum (2):
  Add .gitignore
  Replace own Websocket parser with Protocol::Websocket.

 .gitignore                |   4 +
 PVE/APIServer/AnyEvent.pm | 187 +++++++++++---------------------------
 debian/control            |   1 +
 3 files changed, 58 insertions(+), 134 deletions(-)
 create mode 100644 .gitignore

-- 
2.17.0



More information about the pve-devel mailing list