[pve-devel] applied: [PATCH manager v2 0/3] letsencrypt/certificate gui

Thomas Lamprecht t.lamprecht at proxmox.com
Fri May 4 16:32:42 CEST 2018


On 5/4/18 11:53 AM, Dominik Csapak wrote:
> this series implements a gui for fabians certificate/letsencrypt
> patches, which lets the user upload/delete custom certificates,
> register an acme account, and order/renew letsencrypt certificates
> 
> changes from v1:
> * added a view certificate button
> * added a view account button
> * fixed a missing account load
> * removed debug logs
> * added helper renderer for showing optional urls as link
> * added a note to reload the gui after renewing letsencrypt certicates
> * added a confirm dialog for ACME renewing
> 
> Dominik Csapak (3):
>   add render functions for Certificates
>   add node/ACME.js
>   add node/Certificates.js and use it
> 
>  www/manager6/Makefile             |   2 +
>  www/manager6/Parser.js            |  29 +++
>  www/manager6/Utils.js             |  21 ++
>  www/manager6/node/ACME.js         | 427 ++++++++++++++++++++++++++++++++++++++
>  www/manager6/node/Certificates.js | 379 +++++++++++++++++++++++++++++++++
>  www/manager6/node/Config.js       |   8 +
>  6 files changed, 866 insertions(+)
>  create mode 100644 www/manager6/node/ACME.js
>  create mode 100644 www/manager6/node/Certificates.js
> 

applied, but followed up with the removal of the '(Force) Renew Certificate'
Button for now, as discussed with you off-list. (can be easily reverted,
if we/users say this is must have).

Also updated the dependency version requirements.



More information about the pve-devel mailing list