[pve-devel] applied: [PATCH qemu-server v2] use pve-edk2-firmware for supporting OVMF

Wolfgang Bumiller w.bumiller at proxmox.com
Thu Mar 22 08:39:24 CET 2018


applied

On Fri, Mar 16, 2018 at 01:58:27PM +0100, Thomas Lamprecht wrote:
> depend on new pve-edk2-firmware package and adapt the OVMF CODE/VARS
> path accordingly
> 
> Signed-off-by: Thomas Lamprecht <t.lamprecht at proxmox.com>
> ---
> 
> changes v1 -> v2:
> * adapt path to new location
> 
>  PVE/QemuServer.pm | 5 +++--
>  debian/control    | 1 +
>  2 files changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/PVE/QemuServer.pm b/PVE/QemuServer.pm
> index 5462d07..ca94c01 100644
> --- a/PVE/QemuServer.pm
> +++ b/PVE/QemuServer.pm
> @@ -38,8 +38,9 @@ use Time::HiRes qw(gettimeofday);
>  use File::Copy qw(copy);
>  use URI::Escape;
>  
> -my $OVMF_CODE = '/usr/share/kvm/OVMF_CODE-pure-efi.fd';
> -my $OVMF_VARS = '/usr/share/kvm/OVMF_VARS-pure-efi.fd';
> +my $EDK2_FW_BASE = '/usr/share/pve-edk2-firmware/';
> +my $OVMF_CODE = "$EDK2_FW_BASE/OVMF_CODE.fd";
> +my $OVMF_VARS = "$EDK2_FW_BASE/OVMF_VARS.fd";
>  
>  my $qemu_snap_storage = {rbd => 1, sheepdog => 1};
>  
> diff --git a/debian/control b/debian/control
> index b8aa4ed..cba1016 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -32,6 +32,7 @@ Depends: dbus,
>           pve-ha-manager,
>           pve-qemu-kvm (>= 2.9.1-9),
>           socat,
> +         pve-edk2-firmware,
>           ${perl:Depends},
>           ${shlibs:Depends},
>  Description: Qemu Server Tools
> -- 
> 2.14.2



More information about the pve-devel mailing list