[pve-devel] [PATCH firewall 4/6] debian: drop preinst

Fabian Gr├╝nbichler f.gruenbichler at proxmox.com
Thu Mar 8 13:33:54 CET 2018


the only actual code was for upgrading from PVE 3 to PVE 4..

Signed-off-by: Fabian Gr├╝nbichler <f.gruenbichler at proxmox.com>
---
 debian/preinst | 27 ---------------------------
 1 file changed, 27 deletions(-)
 delete mode 100644 debian/preinst

diff --git a/debian/preinst b/debian/preinst
deleted file mode 100644
index 967b9f8..0000000
--- a/debian/preinst
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-set -e
-
-case "$1" in
-    install|upgrade)
-	old_version=$2
-	if [ -e '/usr/sbin/pve-firewall' ]; then
-	    if dpkg --compare-versions "$old_version" lt '1.0-16' ; then
-		echo "Detected old pve-firewall version - using stop/start to restart"
-		pve-firewall stop
-	    fi
-	fi
-    ;;
-
-    abort-upgrade)
-    ;;
-
-    *)
-        echo "preinst called with unknown argument \`$1'" >&2
-        exit 1
-    ;;
-esac
-
-#DEBHELPER#
-
-exit 0
-- 
2.14.2




More information about the pve-devel mailing list