[pve-devel] applied: [PATCH firewall] api: host, vm: explicit import raise_param_exc

Wolfgang Bumiller w.bumiller at proxmox.com
Mon Jun 18 11:07:08 CEST 2018


applied

On Thu, Jun 14, 2018 at 12:08:52PM +0200, Thomas Lamprecht wrote:
> we inherited the import from PVE::RESTHandler but may want to get rid
> of it there. So explicitly import it here.
> 
> Signed-off-by: Thomas Lamprecht <t.lamprecht at proxmox.com>
> ---
>  src/PVE/API2/Firewall/Host.pm | 2 ++
>  src/PVE/API2/Firewall/VM.pm   | 2 ++
>  2 files changed, 4 insertions(+)
> 
> diff --git a/src/PVE/API2/Firewall/Host.pm b/src/PVE/API2/Firewall/Host.pm
> index bbc34c5..2500bd0 100644
> --- a/src/PVE/API2/Firewall/Host.pm
> +++ b/src/PVE/API2/Firewall/Host.pm
> @@ -2,6 +2,8 @@ package PVE::API2::Firewall::Host;
>  
>  use strict;
>  use warnings;
> +
> +use PVE::Exception qw(raise_param_exc);
>  use PVE::JSONSchema qw(get_standard_option);
>  use PVE::RPCEnvironment;
>  
> diff --git a/src/PVE/API2/Firewall/VM.pm b/src/PVE/API2/Firewall/VM.pm
> index 644d6bb..adb0655 100644
> --- a/src/PVE/API2/Firewall/VM.pm
> +++ b/src/PVE/API2/Firewall/VM.pm
> @@ -2,6 +2,8 @@ package PVE::API2::Firewall::VMBase;
>  
>  use strict;
>  use warnings;
> +
> +use PVE::Exception qw(raise_param_exc);
>  use PVE::JSONSchema qw(get_standard_option);
>  use PVE::Cluster;
>  use PVE::Firewall;
> -- 
> 2.17.1



More information about the pve-devel mailing list