[pve-devel] [PATCH kernel 4/4] d/rules: check for accidental perf linkage

Fabian Gr├╝nbichler f.gruenbichler at proxmox.com
Tue Apr 24 13:57:30 CEST 2018


with libraries that are not GPL-2-only compatible.

Signed-off-by: Fabian Gr├╝nbichler <f.gruenbichler at proxmox.com>
---
 debian/rules | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/debian/rules b/debian/rules
index a84ae5a..cb892d2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -125,7 +125,10 @@ binary: install
 	touch $@
 
 .tools_compile_mark: .compile_mark
-	${MAKE} -C ${KERNEL_SRC}/tools/perf prefix=/usr HAVE_CPLUS_DEMANGLE=1 NO_LIBPYTHON=1 NO_LIBPERL=1 NO_LIBCRYPTO=1 PYTHON=python2.7
+	${MAKE} -C ${KERNEL_SRC}/tools/perf prefix=/usr feature-libbfd=0 HAVE_CPLUS_DEMANGLE=1 NO_LIBPYTHON=1 NO_LIBPERL=1 NO_LIBCRYPTO=1 PYTHON=python2.7
+	echo "checking GPL-2 only perf binary for library linkage with incompatible licenses.."
+	! ldd ${KERNEL_SRC}/tools/perf/perf | grep -q -E '\blibbfd'
+	! ldd ${KERNEL_SRC}/tools/perf/perf | grep -q -E '\blibcrypto'
 	${MAKE} -C ${KERNEL_SRC}/tools/perf man
 	# contained in linux-base
 	rm -f ${KERNEL_SRC}/tools/perf/Documentation/perf.1
-- 
2.14.2




More information about the pve-devel mailing list