[pve-devel] iproute2 package for kernel 4.15 ?

Fabian Gr├╝nbichler f.gruenbichler at proxmox.com
Fri Apr 20 10:37:32 CEST 2018


On Fri, Apr 20, 2018 at 10:33:31AM +0200, Alexandre DERUMIER wrote:
> >>iproute2 4.15 contains a bug in /bin/ss which is in use in the next PVE. 
> 
> Just curious, where proxmox is using /bin/ss ?

https://git.proxmox.com/?p=pve-common.git;a=blob;f=src/PVE/Tools.pm;h=d5373a4246062887bd778f35f4d2ac9cf2bb8bd1;hb=refs/heads/master#l804

> 
> man said:
> "ss is used to dump socket statistics. It allows showing information similar to netstat.  It can display more TCP and state informations than other tools."
> 
> 
> Seem to be fixed here:
> https://www.spinics.net/lists/netdev/msg486801.html

we'll (probably) upgrade the iproute2 packages (including the fix above)
together with switching the default kernel from 4.13 to 4.15.



More information about the pve-devel mailing list