[pve-devel] [PATCH qemu v2 0/5] Provides a qemu-system-x86 virtual package

Emmanuel Kasper e.kasper at proxmox.com
Mon Oct 16 11:05:08 CEST 2017


> In general, looks good to me.
> 
> Upstream package provides also the following man pages[1]:
> /usr/share/man/man1/qemu-system-i386.1.gz
> /usr/share/man/man1/qemu-system-x86_64.1.gz

> Which we do not (we have only qemu), would it make sense
> to make a link to these?

yes makes sense, we should install symlinks for this, and not a qemu man
pages since neither we nor debian provides a qemu man page

I will send a new version of 4/5 covering this


> Additionally to this, would it be possible to remove the postinst?
> AFAIS, the single use for it was to allow the transition from
> keeping the ifup/down scripts in /etc/kvm and not /etc/qemu and
> that happened in PVE 2.2 (2012), so it should be safe to remove it
> for 5.1 as no direct upgrade from 2.2 to 5.1 is possible/
> recommended/...
> But that isn't really urgent and can be done later.
> 
> [1] https://packages.debian.org/de/stretch/amd64/qemu-system-x86/filelist

this should be addresses in another patch serie IMHO




More information about the pve-devel mailing list