[pve-devel] [PATCH manager 3/7] ui: ha: make vote warning shorter

Thomas Lamprecht t.lamprecht at proxmox.com
Wed Oct 11 12:09:43 CEST 2017


Signed-off-by: Thomas Lamprecht <t.lamprecht at proxmox.com>
---
 www/manager6/ha/ResourceEdit.js | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)

diff --git a/www/manager6/ha/ResourceEdit.js b/www/manager6/ha/ResourceEdit.js
index a70a1c75..f57668e8 100644
--- a/www/manager6/ha/ResourceEdit.js
+++ b/www/manager6/ha/ResourceEdit.js
@@ -25,7 +25,7 @@ Ext.define('PVE.ha.VMResourceInputPanel', {
 	var MIN_QUORUM_VOTES = 3;
 
 	var disabledHint = Ext.createWidget({
-	    xtype: 'displayfield', //submitValue is false, so we don't get submitted
+	    xtype: 'displayfield', // won't get submitted by default
 	    userCls: 'pve-hint',
 	    value: 'Disabling the resource will stop the guest system. ' +
 	    'See the online help for details.',
@@ -36,11 +36,7 @@ Ext.define('PVE.ha.VMResourceInputPanel', {
 	    itemId: 'fewVotesHint',
 	    xtype: 'displayfield',
 	    userCls: 'pve-hint',
-	    updateValue: function(votes) {
-		var me = this;
-		me.setValue('You need at least three quorum votes for a reliable HA cluster. ' +
-		'See the online help for details. Current votes: ' + votes);
-	    },
+	    value: 'At least three quorum votes are recommended for reliable HA.',
 	    hidden: true
 	});
 
@@ -59,7 +55,6 @@ Ext.define('PVE.ha.VMResourceInputPanel', {
 		});
 
 		if (votes < MIN_QUORUM_VOTES) {
-		    fewVotesHint.updateValue(votes);
 		    fewVotesHint.setVisible(true);
 		}
 	    }
-- 
2.11.0




More information about the pve-devel mailing list